Supercharger problems.

  1. Welcome to Toyota Tundra Forums : Tundra Solutions Forums General discussion forum for Toyota Trucks

    Welcome to Toyota Tundra Forums : Tundra Solutions Forums - a website dedicated to all things Toyota Tundra.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Toyota Tundra Forums : Tundra Solutions Forums today!
     
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 24

Thread: Supercharger problems.

  1. #1
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233

    Default Supercharger problems.

    Hey everyone, just join this forum recently and this is my first post . Anyways first off I have a 2008 5.7 Crewmax, with recently installed supercharger. Im wondering if any other s/c tundras are experiencing this problem and if anyone has any solutuions that the dealership might not know about. Well I had my s/c installed Saturday and when i picked it up it ran like a champ, couldnt keep wheels from spinning so much power. Well after filling up w/chevron supreme, full tank i might add, it started bogging out after about an hour, but only when i floored it. Two codes came on P0171/4 Too lean bank 1 & 2 . Took it back to dealership and first they said it was tested as bad gas, and than it was still running crappy, so they tested and said new fuel pump was bad. So they replaced it, picked it up on tuesday, ran awesome. That was yesterday, and today its no bogging out like it wants to die, but its a delay and small bogging affect, but def not taking off like it did before. Tire barely spin now. I did take traction control off and set these modes everywhich way.

    Has anyone experienced this problem or know any solutions. Im gonna take it back to dealer because it is covered under warranty, and they been really good to me, i just dont understand why this is happening. And no check engine light has come up like last time.
    Any help would be appreciated. Thanks.

  2. Remove Advertisements
    Toyota Tundra Forum
    Advertisements
     

  3. #2
    Supercharged Member RONE's Avatar
    Join Date
    May 2007
    Location
    Merriam, KS
    Posts
    2,533
    Liked
    53 times
    Rep Power
    6464

    Default Re: Supercharger problems.

    Yes, I think there have been 2 people on this board with problems like you describe. Use the search function and start reading. I think the fix they found was to install aftermarket headers.

  4. #3
    Junior Member Rocker's Avatar
    Join Date
    Sep 2008
    Location
    USA
    Posts
    393
    Liked
    5 times
    Images
    38
    Rep Power
    622

    Default Re: Supercharger problems.

    I haven't had any problems with mine in 34K miles, but just make sure they did re-flash the ECU to help the fuel and ignition advance curves deal with boost. I don't know if that would cause problems this severe, but it's worth the question. Fuel, air, ignition, and compression are all what make it go. This definitely sounds like a fuel or ignition problem, and therefore quite possibly a computer problem. They should have also changed the fuel injectors when they did the job - are the stock ones in the box of stuff they should have given you when they finished the job?

    Bottom line, though, if you're gonna have problems, have them early! That way the dealer has to buy the repairs. Hope it gets squared away soon.
    Last edited by Rocker; 03-16-2011 at 08:21 PM.
    S/C 2008 Tundra - Banks Monster Exhaust
    2008 5.7 TRD SR5 4X4 DC | TRD Supercharged | Banks Monster single exhaust | Bilstein 5100s | LT275/65R20 Cooper AT3s
    Black Limited 20s | Hellwig Rear Swaybar | Black Headlight Mod | Line-X

  5. #4
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    yeah all new parts from kit, new high volume fuel pump, injectors, new spark plugs, have all old stuff in box here at home.

  6. #5
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    I did install magnaflow exhaust yesterday, but even after that it ran great, until today. I dont believe theres any exhaust leak, but even if there was dont think it would do that you know.

  7. #6
    Veteran Member JasonF1234's Avatar
    Join Date
    Jul 2009
    Location
    Baton Rouge,La
    Posts
    630
    Liked
    3 times
    Images
    17
    Rep Power
    7091

    Default Re: Supercharger problems.

    I had some problems with mine but it was a bad injector. Never had any kind of bogging down of the engine. I have to agree, in it sounds like something in the ECU not letting AFR be consistant. Is it throwing a code when it happens?
    Black Widow

    2/4 Mcgraughy's spindle drop
    Front grill, LED in rims
    LED taillight,LED 3rd Brakelight
    LED's Interior lights,22" Incubus rims
    LED Brakelights, TRD swaybar
    TRD Supercharger, TRD intake
    Priana Body Kit,VIS racing hood
    Doug thorley Long tube headers
    EBC Brakes and Rotors
    Custom 2 1/2 exhaust

  8. #7
    Supporter dragaeran's Avatar
    Join Date
    Dec 2007
    Location
    Atlanta, GA
    Age
    43
    Posts
    598
    Liked
    3 times
    Images
    7
    Rep Power
    126

    Default Re: Supercharger problems.

    mine seems to be very "jerky" when I need to accelerate hard if I am running about 1800-2200 RPM, as if I just dumped the clutch in 2nd. I have also had issues with acceleration from a standstill not being immediate. The delay can be very slight to "gee I think I'll read a book now" slow. Dealer closest to me says I have to take it back to the install dealer up the road cuz they are the ones who installed it and are responsible for the warranty work. I know it's BS, but have not had time to argue the point with them. Also, they won't give me a loaner and I need the truck for work.

  9. #8
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    I guess im taking it backt to the dealer tomorrow. I cant understand it. I dont see how it can run so fine and all off of sudden stop pulling as hard, "jerky" like not responding fast enough and no check engine lights coming on.
    SO noone else has any suggestions.

  10. #9
    Rookie 08rcsb,rst,5.7sc,'s Avatar
    Join Date
    Feb 2011
    Location
    north texas
    Posts
    16
    Liked
    0 times
    Images
    10
    Rep Power
    0

    Default Re: Supercharger problems.

    make sure the pressure port cap is still on the s/c driverside rear os s/c.

  11. #10
    Supercharged Member RONE's Avatar
    Join Date
    May 2007
    Location
    Merriam, KS
    Posts
    2,533
    Liked
    53 times
    Rep Power
    6464

    Default Re: Supercharger problems.

    Quote Originally Posted by jevr2331 View Post
    I guess im taking it backt to the dealer tomorrow. I cant understand it. I dont see how it can run so fine and all off of sudden stop pulling as hard, "jerky" like not responding fast enough and no check engine lights coming on.
    SO noone else has any suggestions.
    Did you search like I suggested? Your problem sounds very similar to some other issues I have read about.

  12. #11
    Veteran Member dariusld's Avatar
    Join Date
    Nov 2007
    Location
    San Diego
    Posts
    1,023
    Liked
    11 times
    Images
    64
    Rep Power
    5437

    Default Re: Supercharger problems.

    Quote Originally Posted by RONE View Post
    Did you search like I suggested? Your problem sounds very similar to some other issues I have read about.
    Sounded familar to me also. Did a quick search and only found re-flash issues dealing with updates. He probably is already getting the newest re-flash available.

  13. #12
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    Yeah i would also believe i was getting the newest reflash available. But like I said, when I got it put on on Sat. it was awesome, then I filled it up with Chevron gas and after running it for maybe about 10 miles i just let it sit at my friends house while we hungout. Then on way home it started bogging out. Took it back to dealer and they said bad gas and bad fuel pump. So then got it back and awesome again, till a day later, I put on my magnaflow exhaust, but still running great then the next day started acting up. I kind of think it might be the fuel pump problem again, or injectors. havent checked the last post about the pressure cap but will next. I put in some fuel injector cleaner and filled with half of tank of gas to maybe clean injectors, according to tech, to see what happens, but either way im taking to dealer tomorrow.

  14. #13
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    ???What does that pressure cap look like anyways?????

  15. #14
    Junior Member Rocker's Avatar
    Join Date
    Sep 2008
    Location
    USA
    Posts
    393
    Liked
    5 times
    Images
    38
    Rep Power
    622

    Default Re: Supercharger problems.

    It's just a black vacuum cap on the rear driver side of the supercharger itself. It is unobstructed and you'll be able tell in about one second if its there or not. Mine went missing a couple of months ago (still not sure how - it's vacuum) and ended up throwing a code for being too lean. I threw a new one on there - good to go. However, while I was cruising around with no vacuum cap on there, I didn't really have any drivability issues like what you're describing. The supercharger did run a little louder though.
    S/C 2008 Tundra - Banks Monster Exhaust
    2008 5.7 TRD SR5 4X4 DC | TRD Supercharged | Banks Monster single exhaust | Bilstein 5100s | LT275/65R20 Cooper AT3s
    Black Limited 20s | Hellwig Rear Swaybar | Black Headlight Mod | Line-X

  16. #15
    Lurking Member
    Join Date
    Mar 2011
    Location
    Deer Park
    Posts
    30
    Liked
    0 times
    Rep Power
    233
    Thread Starter

    Default Re: Supercharger problems.

    So I dropped it off at dealer today, was going to take awhile to get to it, they supplied me with rental and went on my way. I have a friend that works up there and I asked him if they had figured it out and he said they are odering me a new fuel pump computer, so theyre not really sure if thats the problem but i guess well see once they install it. Ill keep everyone updated.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •