Rough at low throttle with load. - Toyota Tundra Forums : Tundra Solutions Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-30-2018, 12:00 AM Thread Starter
Rookie
 
Join Date: Feb 2002
Location: Mission Viejo, CA
Posts: 3
 
Unhappy Rough at low throttle with load.

But when at high RPM it sounds great. Example being, accelerate to 65 mph. Back off on throttle and barely any pressure to maintain the 65 mph and truck feels/sounds/acts like it is starving for fuel. Low speed up hill, same symptoms - cruising along, it shifts to second and acts the same way until the RPM gets up.

I changed fuel filter no difference. timing belt 2000 miles ago, ran great until now..... ran great yesterday - this all started today. no rat damage, no rain, no zombies.

I thinking of getting a an overhaul of all the injectors (2000 Tundra V8 138,000 miles)

H E L P
Kirby is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota Tundra Forums : Tundra Solutions Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome