Help!!!!! Codes popping up all at one time!!!! - Toyota Tundra Forums : Tundra Solutions Forum
 1Likes
  • 1 Post By jestersmith
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 08-08-2018, 06:49 AM Thread Starter
Rookie
 
roystundra's Avatar
 
Join Date: Mar 2015
Location: Panama City, FL
Posts: 17
 
Help!!!!! Codes popping up all at one time!!!!

02 Tundra 4.7 275,000 Miles. Everything was running fine. I was driving down a busy road and turned around in the center and BAM, truck started skipping and bucking. I drove straight to AutoZone and had it checked. Both o2 sensors code came up and #4 and #7 had random mis firing and the TPS code came up and and the Clutch in the throttle motor, sorry I can not remember the name of it, so I went ahead and changed both 02 sensors, TPS, all Coil paks, Spark plugs "they actually needed to be changed" , fuel filter and cleaned the Throttle Body and MAF. The truck did run a lot better, it stopped the bucking and skipping. The codes did not clear after. Tried clearing them with the hand held also, to no avail. Now when the truck is idling it will be smooth then it will miss twice, like dup, dup and then smooth out again with the A/C on or off. What am I over looking? I believe it is a sensor that I am over looking or do I need to just replace the whole Throttle Body assembly? Thanks in advance for your help. I am good at mechanical, but the only thing I know about electricity is that, it will shock you.

Help some one today, because tomorrow you might need their help.

Last edited by roystundra; 08-08-2018 at 06:57 AM.
roystundra is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-08-2018, 08:23 AM
Lurking Member
 
Join Date: Mar 2018
Location: Alberta, Canada
Posts: 22
 
Re: Help!!!!! Codes popping up all at one time!!!!

I doubt you'd need to replace the entire throttle body assembly. Is it blowing any smoke? You've replaced quite a bit, so I'm wondering about fuel (did you just fill somewhere), fuel filter, crankshaft position sensor (not sure what the symptoms of this one would be or if it would even run), timing belt slip (when was the last time it was replaced?), timing in general. Ah, that's a tough one. You cleaned the MAF, but did you test it on a meter to make sure it's working -- try that. There are instructions online / youtube. It won't shock you.
jestersmith is offline  
post #3 of 8 (permalink) Old 08-08-2018, 08:39 AM Thread Starter
Rookie
 
roystundra's Avatar
 
Join Date: Mar 2015
Location: Panama City, FL
Posts: 17
 
Re: Help!!!!! Codes popping up all at one time!!!!

Thanks Jester, No it is not blowing any smoke. The fuel should be good. I run 98 octane and it seems to get better MPG when I run it. I changed the fuel filter during this little venture also. It is actually due for a timing belt replacement and I am now in the process of saving the $ to get this accomplished. I could actually do it myself, but thanks to my ex, I have no tools worth having and no place to do the job, I am having a local mechanic to do the install. I will check the MAF also just to see if that helps any. Thank you again.
P.S. Would the TPS on the passenger side of the Throttle body make it miss fire or does it really sound like it slipped timing?

Help some one today, because tomorrow you might need their help.

Last edited by roystundra; 08-08-2018 at 08:42 AM.
roystundra is offline  
 
post #4 of 8 (permalink) Old 08-08-2018, 09:36 AM
Lurking Member
 
Join Date: Mar 2018
Location: Alberta, Canada
Posts: 22
 
Re: Help!!!!! Codes popping up all at one time!!!!

I'm not sure what it would do other than run rough (as I have yet to experience that issue), but I thought you had replaced the throttle positioning sensor.

Slipped timing, I'm not sure how common that is but maybe if it is loose and time to replace and you stomped the pedal to the floor, perhaps that could cause a tooth to slip (not sure if even possible).

Yes, that would be a tough one with no tools and no shop. I was surprised when I did mine how much crap you have to remove before you can even get to it. There's a good well-priced Aisin kit with water pump and bearings on Amazon. I used this kit and it was great (as did many others). Might save some money on parts there if you bring it in with you.


Timing doesn't explain why the codes won't clear though I think, so leads me back to MAF.

Last edited by jestersmith; 08-08-2018 at 09:54 AM.
jestersmith is offline  
post #5 of 8 (permalink) Old 08-08-2018, 10:14 AM Thread Starter
Rookie
 
roystundra's Avatar
 
Join Date: Mar 2015
Location: Panama City, FL
Posts: 17
 
Re: Help!!!!! Codes popping up all at one time!!!!

I did replace the TPS. The Pedal Position Sensor on the passenger side is the only one that I didn't replace.

It cranks fine and runs fine, but when just sitting at idle, you can hear it and feel it miss like two times and then back to normal and then after a little bit more of sitting and idling it misses again.

I do remember hearing a clicking noise every now and then in the Throttle motor on the driver side top of the throttle body, but haven't seen a thread covering this issue yet.

Help some one today, because tomorrow you might need their help.
roystundra is offline  
post #6 of 8 (permalink) Old 08-08-2018, 10:21 AM
Lurking Member
 
Join Date: Mar 2018
Location: Alberta, Canada
Posts: 22
 
Re: Help!!!!! Codes popping up all at one time!!!!

Ah OK. Test the MAF, and dump a bottle of fuel injector cleaner in the tank. Check all your vacuum lines as well. I don't know anything about that pedal position sensor and if that would cause a rough idle, but if cheap could try that as well if all else fails.

I do know that when I cleaned my MAF and had it unplugged, those same codes came up for me. As soon as cleaned and I reinstalled it -- all gone after clearing. It was weird at the time because I was wondering why it's telling me 02 sensors in addition to the MAF. But, once I plugged it back in, no codes (and I never touched the 02 sensors).
roystundra likes this.

Last edited by jestersmith; 08-08-2018 at 10:27 AM.
jestersmith is offline  
post #7 of 8 (permalink) Old 08-09-2018, 05:03 AM Thread Starter
Rookie
 
roystundra's Avatar
 
Join Date: Mar 2015
Location: Panama City, FL
Posts: 17
 
Re: Help!!!!! Codes popping up all at one time!!!!

I will try that before I replace the Pedal Position Sensor for sure. It costs $300.

Thanks again Jester

Help some one today, because tomorrow you might need their help.
roystundra is offline  
post #8 of 8 (permalink) Old 08-09-2018, 12:02 PM
Lurking Member
 
Join Date: Mar 2018
Location: Alberta, Canada
Posts: 22
 
Re: Help!!!!! Codes popping up all at one time!!!!

Yikes.



You bet.
jestersmith is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota Tundra Forums : Tundra Solutions Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome