P0156 on B2/S2 - newish sensor - Toyota Tundra Forums : Tundra Solutions Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 10-30-2018, 10:58 AM Thread Starter
GTT
Lurking Member
 
Join Date: Jan 2016
Posts: 31
 
P0156 on B2/S2 - newish sensor

Hey All,

My time to pass emissions here in CT has come up and I am scrambling to make my 02 4.7 Tundra compliant. I have had a CEL P0156 for about a year, and recently went underneath to see what was up. Found both rear O2 sensors dangling after their flanges rusted away. The drivers side has never given me problems, passenger side was replaced about 2 years ago when I had another CEL, and was able to drive cycle and pass.

Because I'm cheap and more because this Tundra has the rust w/ no remediation from TOA, I am loathe to put money into it. Thinking that B2S2 was new I epoxy puttied them back in place. Driver side is fine but passenger side is showing very little voltage if any (sometimes I can get a little spike, but otherwise it's a flat line).

I will note that the cat to collector pipe flange is leaking bad. There is probably zero gasket left there and you can feel it easily. This flange is about 3-4 inches downstream of THAT O2 sensor so it's making me wonder if it's not creating a false lean reading... but I'm not sure how far air can get sucked back. Otherwise, it does not seem to be leaking around the sensor itself despite my jerry rigged epoxy job. It's possible that dangling for a year has caused it to go bad, what with grime, road salt/mud, and/or banging around, but from my experience they are pretty resilient.

Before I go grinding the epoxied sensor out and trying to somehow glue it back in, I'm trying to exhaust all options (no pun intended :P) that might be causing this to be lean. I have no plans to replace cats or any major expense.... the thing is going on 16 years old the frame maybe has a couple more good years. Very sad because it only has 95K miles and is otherwise in great shape. If I can't get it to pass I will just ignore emissions and wait until the registration runs out next year, then part it out and get something else.

Attached is a Torque pull for half a drive cycle. Thanks for any advice!
Attached Images
File Type: jpg attachment1.jpg (401.5 KB, 2 views)
GTT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota Tundra Forums : Tundra Solutions Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome