Toyota Tundra Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 1Gen-Tundra
    Hi all, a little background: Last week I started my truck (2005 SR5, AC, 4x2, Auto, 190k miles) and it instantly died. After 2 or 3 attempts it finally started but had a very bad misfire. I shut it off and when I hooked up my scan tool (to check the misfire) it started and ran fine. Ran good...
  2. 2Gen-Tundra
    Problem started all the sudden running really rough then shut off and wouldn’t start or crank. The batteries a week old I unbolted and bench tested the alternator. The fuel light came on but there is plenty of fuel the gauge is reading random amounts. The EFI no. 1 fuse was blown I replaced the...
  3. 2Gen-Tundra
    I've had this issue for years but it's only recently gotten worse. On hot days, when the truck is baking in the sun, it will not crank/start late in the afternoon. I've taken it to both the dealership and a trusted mechanic who, of course, can't replicate it. Getting tired of it happening more...
  4. Engine & Drivetrain
    The truck has 160k miles and with no warning just a click when starting. Got the battery tested at the local O'Reilly and it failed. Purchased a new battery, cleaned connectors, and had a tight connection...just a click still. Check all grounds for corrosion, blown fuses, and check starter...
  5. 1Gen-Sequoia
    I replaced the serpentine belt of my wifes 05 Sequoia and when done the truck would not crank, no clicking sound from the starter relay but all dash lights are working. I tought it was the alarm system because my wife told me it happened to her before and she just tried arming and disarming the...
1-5 of 5 Results
Top