Toyota Tundra Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So my wife's 01 Camry has had these codes now for a bit, took the car to the shop twice which almost cost about $500 worth of work. They replaced the EGR VSV, the EGR vacuum modulator as well as a few other things that had to be done. The shop says everything worked fine the last time they ran it, so to bring it in again they want more $$$, which isn't happening. I started doing work on it to try and find the problem first by disconnecting the hose that connects to the EGR valve (car still ran fine) then applied vacuum using a vacuum pump. The vacuum applied never dropped, but the car ran very poorly which leads me to believe the EGR valve is fine? Can someone point me in the next direction I should be focusing on, I am assuming the next step would involve cleaning the Intake somehow
 

·
Registered
Joined
·
58 Posts
I had an intermittent CEL couple years ago same codes. Finally broke down and replaced my cat converter. Also started with same parts you already replaced and didn't help either. Waited for a coupon code from partznet ended up paying approx 262 bucks for it shipped. This is the whole front manifold bolts to the head all the way down to the down tube. Very easy install reset CEL and has been at least a 2yrs and has not come back on. Really the only reason I replaced it is so i could get it inspected although i was tired of the CEL. I have been lucky last couple years and light has cut off close to inpection being due. It would go off 2-3 times per year.

Later Matt
 
1 - 2 of 2 Posts
Top