Toyota Tundra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My old girl won't start, all of a sudden. Drove it Monday, big lightning strike near the house where she's parked on Tuesday, don't think anything of it until go to start her on Wednesday or Thursday and she cranks good but won't start. Lights come on inside, security light is flashing regularly, beeps if door is open, everything seems normal. All the fuses checked with multimeter and are good. No power at fuel pump, though. So wondered if it was something to do with the security system which shuts off the fuel? Tried another key, no difference. Tried disconnecting battery for a while, no difference. Someone suggested turning the key on in the ignition and leaving it there without trying to start for about 20 minutes to reset the security system (says it works on some domestic cars).

I figure it's either something simple, like the security system needs reset, or something bad, like lightning fried some of the guts. I've been looking through here for hints but didn't find anything that quite fits ... any ideas? Is there a way to force a security reset, or a way to isolate the problem to just the fuel pump?

We have the "brake light comes on at random" problem too, which some people have said points to the ECU ... could that have failed?

I'm way out in the sticks and having the vehicle towed to a repair shop will be expensive, so I'd really like to get it at least running ...

Thanks, all ...Kentuckienne
 

·
Registered
Joined
·
2,966 Posts
all security systems have a reset button but usually the fatory ones are on the control box for the sequrity and its hard to get to for a reason. aftermarket usually have a that can be place somewhere easy for the owner and hard for an intruder.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Disconnecting the battery for a longer time didn't reset the security system, if that's what's causing the problem. Is that how it's supposed to work? Do I need to find this reset button? It seems actually that the system is working because when I try to start, I see the red flashing security light on the console. I read somewhere else in this forum that an ECU failure will shut off the fuel pump as a precautionary measure...is there a way to check the status of the ECU without a code reader?
 

·
Premium Member
Joined
·
180 Posts
Do Sequoia's have a fuel pump reset switch? I know some vehicles have a reset switch that shuts off the fuel in an accident. I've seen them under the glove box before.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
I don't know about this ... it's not in the owner's manual. Is this a Sequoia/Tundra secret?

I am now informed that the actual problem is that "the fuel pump relay coil is not being energized" aka "no power to fuel pump relay". Does this further implicate the computer as the culprit?
 

·
Registered
Joined
·
422 Posts
Do you know if yours has an imobiliser system? Aka chip in the key?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
New computer, more codes

OK, towed the car to a shop. They replaced the computer with a used computer, and actually took it to the local dealer to get that programmed. After driving partway home, the ABS light came on. Took it back so they could put it on the scanner ...code 1203, code 1223 (they said this was related to ABS) and code 1244 (they said this was open/short deceleration sensor). I wonder if this is just another bad computer with its own problems, or if these other problems were caused by the lightning (assuming that's what blew up the computer the first time)?

I'll take it back to them to deal with, but I hate to spend a lot of money replacing other things if it's the computer. Is there a way to be sure that the used computer they put in is OK?
 
1 - 8 of 8 Posts
Top