Toyota Tundra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
It cranks fine ,but won't start ...poured gas in the throttle body and started up and ran until gas burned out...so dropped gas tank and checked fuel pump it won't run unless wired direct from battery... so changed out fuel pump relay and still no go...is there a fuse or a sensor that could be holding the relay out ...mudder:clumsy:
 

·
Registered
Joined
·
3,058 Posts
I can't find a Sequoia schematic, but I may be able to point you in the right direction. I would check all the fuses first. Pin 30 on the relay should have power to it. Check continuity to ground on pin 86. Pin 85 should power up with the key on, causing the relay to click. If everything checks out up to this point, there is damaged wiring btw. the relay and fuel pump. Hopefully it is just a blown fuse.
 

·
Registered
Joined
·
3,058 Posts
I would think there is, but I couldn't find a Sequoia manual to check for sure. If you have the owner's manual, it should say in there. If not, start checking all the fuses with a test light or removing and visually inspecting them. The fuse may not be labeled fuel pump.
 

·
Registered
Joined
·
44 Posts
On my 2008 Sequoia Platinum, the following fuses/relays are associated with the Fuel system; 1, 3, 16, 21, 26, 30, 35, 53 and 54.



There is also a fuel pump shut off system that activates anytime the vehicle stalls...or when an air bag deploys. So, i suppose it it could be possible for this shut-off system to malfunction..and prevent power from going to the fuel pump.

Hope this helps, Toolman_Johnny
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for the picture ,but problem was found...So I'll tell on myself when I replace the power antenna I did't press one of the wiring harness back together all the way, but now I have new fuel pump and relay...Old pump had 220000 miles on it so it was time......mudder
 
1 - 7 of 7 Posts
Top