Toyota Tundra Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter · #1 ·
Long story short: I had to go put a battery in my mom's car this morning, and when we got it in and cranked it up, it ran fine. Turned on the AC and the car almost stalled to a stop.

I have checked the alternator, and it is charging the battery when cranked. I've done some quick Googling and have came across two possible issues: 1) an idle-up valve - possible bad valve or bad/cracked vacuum lines and 2) the A/C compressor going bad / seizing up.

Does anyone have any help/clues/ideas for this situation?

It idles fine (~700+ RPM) with t he AC off, but the minute you turn it on, the RPMs at idle drop to the point where the engine sounds like it is going to stall and the engine shakes badly.

Thanks in advance.
 

·
Registered
Joined
·
1,573 Posts
It seems to me the compressor is probably the problem.
My 2011 camry a/c feels like outside vented air unless I have it on Recirculate.
 

·
Premium Member
Joined
·
2,388 Posts
Long story short: I had to go put a battery in my mom's car this morning, and when we got it in and cranked it up, it ran fine. Turned on the AC and the car almost stalled to a stop.

I have checked the alternator, and it is charging the battery when cranked. I've done some quick Googling and have came across two possible issues: 1) an idle-up valve - possible bad valve or bad/cracked vacuum lines and 2) the A/C compressor going bad / seizing up.

Does anyone have any help/clues/ideas for this situation?

It idles fine (~700+ RPM) with t he AC off, but the minute you turn it on, the RPMs at idle drop to the point where the engine sounds like it is going to stall and the engine shakes badly.

Thanks in advance.
If the a/c was working fine before the battery change give the engine ECU some time to reset after going without battery power while the change took place. It has to relearn it's settings after a battery disconnect. Should only take a day of driving for it to do that.

Larry
 

·
Registered
Joined
·
24 Posts
Hey Jared, did you ever resolve this issue? I am having the same problem with my step-moms camry. It's a 2008 4 cyl with 28k on it. The battery died today and once we switched it the car started running really rough only with the A/C on.
 
1 - 5 of 5 Posts
Top