Toyota Tundra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello Everyone! I have a 2005 Tundra 4.7 V8. I lost throttle response a few weeks ago. I ran a diagnostic test and got a several codes, all dealing with throttle sensors. I pulled the throttle body off and cleaned it, still no throttle. Bought a new throttle body and new accelerator pedal (since 2005 tundra's have no replaceable sensors, fly-by-wire style) After replacing the throttle body, I still had no results. I replaces the Accelerator pedal assembly, all codes cleared and it ran GREAT for 1 day.
Now its back in limp mode and I now have Code: P2118 (Throttle actuator control motor current, range performance). After everything I've read, I've checked: Wire/Continuity; Good. Fuses; All Good.

Any Suggestions??????
 

·
Registered
Joined
·
1 Posts
Have you checked the APPS & Tps signals at the pcm, also check the output signals to the throttle body actuator, the code tell me that the TBA motor is pulling too much amperage, if all checks out with Apps, tps then I would suspect TB shaft is binding causing elevated amp draw (Just because new doesn't mean it is good) N. E. W =Never Ever Worked! ?
 

·
Registered
Joined
·
25 Posts
You could try spraying down the shaft and butterfly valve with penetrating oil as well as taking off the throttle body and re-greasing the gear set inside, something may be binding and tripping a security code to prevent damaging the actuator.

Again check the voltage, Here is toyota's suggestion to fix this problem: file:///C:/Users/Grier%20Martin/Documents/Sequoia%20Service/2005_Sequoia_Repair_Manual.pdf#page=570
It's quite possible that it's the throttle body itself.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Hello Again Grier,
I've been out and haven't been able to work on my truck in week or so. I followed the repair manual and everything checked out. After talking to a tech, he told me that more than likely it's the ECM. So, I bought one, installed it, and still having the same problem. I'm waiting on a new throttle body to see if that will fix it.

2 Things that I've noticed is: The error code P2118 comes on when I turn the key to on, not start. Also, the code is there with others whenever I turn the key and the throttle body is disconnected.

Do you have any other suggestions while I wait for my part. I live in a remote part of Alaska and it takes awhile before things arrive to me.
Thanks again for your help!
 
1 - 5 of 5 Posts
Top