Toyota Tundra Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all
Q for you. At cold start it idles high as it should then slowly drops then idles back up then down then back up. Any idea what needs to be addressed ?
 

·
Registered
Joined
·
6,093 Posts
Hi all
Q for you. At cold start it idles high as it should then slowly drops then idles back up then down then back up. Any idea what needs to be addressed ?
Mine will do that in the cold weather all the time, but it’s usually several minutes between cycling. My guess is the RPMs are too low in idle?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
I’m not sure but I would like to get it smoothed out. The gradual descend is what I am used to with Toyota’s
 

·
Registered
Joined
·
3,027 Posts
AC compressor? Is your vent selector set to defrost?
 

·
Registered
Joined
·
3,027 Posts
AC doesnt have to be on, if your dial is set to defrost that will cycle the compressor which does cycle on and off and that changes the revs.
 

·
Registered
Joined
·
1 Posts
I had those same symptoms recently on my 06 DC Tundra. Upon cold start, initial idle would jump to around 1.5k, decrease, then cycle through 0.6-1.0k RPM every 5-10 seconds (definitely concerning). Check engine light came on a week later with code P2195. Replaced the upstream, driver side 02 sensor and it's now smoothed back out. Seems that bad info being sent from that O2 sensor was the cause of my yo-yo-ing cold start RPMs.
 
1 - 9 of 9 Posts
Top