Toyota Tundra Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Sorry this is so long but I'm trying to include every detail related to my issue...

I have a 2007 5.7L TRD Off-Road w/ tow package (no factory brake controller) and I ordered a Tuson RV DirecLink DL-100 brake controller. Got it installed but I'm not getting any voltage from the blue wire at the 7-pin receptacle. The blue wire ohms out from the plug behind the kick panel all the way to the receptacle and the blue wire on the brake controller harness ohms out from plug to plug. All other lights and 12v power in the 7-pin work properly. When monitoring the output on the controller screen, the unit is showing 13.5v when activating the brake but 0.0 Amps. The controller I have is a proportional controller using input from the trucks ECU via the OBDII port. When looking through the manual, I noticed that it said it was compatible with 2008 - Present Toyota Tundra When I ordered it I had to enter my truck make & model and I even got a call from their customer service concerning the shipping of multiple items I ordered. The representative never mentioned that it wasn't compatible with the 2007 Tundra. I guess my question is... what is the difference between the 2007 & 2008 Tundra ECU that would prevent it from working on the '07? Could it be a feature that needs to be enabled on the ECU by the dealer? I can't bring home our new travel trailer until I get this figured out. Any help will be greatly appreciated! Thanks!
 
1 - 1 of 1 Posts
Top