Toyota Tundra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I think the factory JBL audio system (stereo only, no GPS) in my 2009 Camry has just about died. Several times over the past few years, but after it was out of warranty, the display wouldn't display even though the light come on. This always happened only when it was really cold, usually when I got off work early in the morning. If I went out after waking up the next afternoon, after the car had warmed up in the garage, the problem would typically have went away. In addition to no display, none of the buttons work except for the on/off/volume knob. If press any of the preset or control buttons, including the load or eject CD buttons, the radio would turn off, then, a couple of seconds later, the display light would go out. I was able to control just fine using the hands-free controls on the steering wheel, though I really couldn't see anything since the display was only lit, but not displaying characters. This would typically happen only a couple of times throughout a winter season.

Now we've had our first cold night. It was about 22 deg F when I left work a couple of mornings ago. I turned the car on, turned my radio on, and the same old problem was there. The only difference is that no amount of warming up seems to be correcting the problem. It's been a few days now and the radio display doesn't appear to be coming back. Whatever it is that is causing this, it seems to be permanent this time. The radio works, I just have no display. I cannot listen to CDs since I can't load or eject them. Pressing the buttons causes the unit to shut down. I still have control through the steering wheel controls.

Has anyone ever experienced anything like this before? Are the radios typically a repairable item through Toyota or would I be better off taking it to some stereo installation/repair place?

Thanks.

- Byron Followell
 

·
Registered
Joined
·
52 Posts
Had similar happen to my wife’s 09. Screen would light up but no info displayed. When any buttons were pushed it would start ejecting cds. Hers only did it when the A/C was on high for a while. I think these systems are very sensitive to cold and or condensation. Took it to the dealer since it was still under 36k and they said they replaced the radio. Worked well for a while. Occasionally will act up but very seldom.
 

·
Registered
Joined
·
85 Posts
Our 2010 Camry XLE, V4, is skipping randomly discs and will do it hours long. Anyone knows if there is/was a TSB on the 2010 Camry Radio Unit?

Can anyone confirm the info? Appreciate your inputs...

Thanks
 
1 - 3 of 3 Posts
Top