Toyota Tundra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok I'll start by saying I have read and done all comments on this forum and still have a squeak. It happens when the suspension moves like when I hit a bump or whatever, I know for a fact it is coming from the front left, when I first got the truck I sprayed soapy water on all the bushings on that side and it stopped for a few days but I did not pin point which bushing was squeaky, I have since tried to pin point it and also added grease zerks to the lca's and greased and still have the squeak I then sprayed every bushing individually and it didnt go away this time. What am I missing?
 

·
Registered
Joined
·
74 Posts
try this.

Check your hood bumpers.
I had a squeak similar to what you described and finally found it.
It was the hood moving across the front hood bumpers and they were dry.
I applied a little silicone grease and it never came back.
Easy fix for what was an annoying problem.
 

·
Registered
Joined
·
6 Posts
Man I found the noise and fixed it finally, I bought the truck used and found it didnt have shock bushing on bothe front shocks put new ones on and no more squeak
Great to hear you figured it out. The previous owner must have forgotten that shock bushing.
 

·
Registered
Joined
·
2,957 Posts
I think the best thing here is Zpre came back to say what the problem was. Too many times people come on here with a question and never come back to say what problem was and are never heard from again. All that does is leave others hanging. You maybe didnt think about it but you may end up helping someone else in the future find a similar problem. We need more of that hear, nice work Zpre.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
cheapskate
Toyota Tundra Forums
Tundra Solutions Forum - the best community to talk, mods, price, repair and research your Toyota!
Full Forum Listing
Top