Toyota Tundra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am hoping someone can help me with this issue. My van has 140K miles. I replaced 6 spark plugs with Denso Iridium a month ago. Now, the engine is a little shake when driving with 3 lights stayed on (AWD, Engine Check, and Trac Off). My OBDII shows three codes (P0302 P0304 P0306) on bank 2.

What could be the problem? I replaced the ignition coil on cylinder #6 just to test. But the OBDII still showed the same trouble codes(P0302 P0304 P0306).

Thanks
 

·
Registered
Joined
·
3,288 Posts
 

·
Registered
Joined
·
1 Posts
My problem (with that code)ended up being clay in my gas tank.(dirt dobber nest) Fuel filter was clogged. Replaced fuelpump, fuel filter after draining & cleaning gas tank , runs like a charm.
 

·
Registered
Joined
·
13 Posts
Before you start throwing a bunch of money at it simply check that all your plug wires are snapped securely to your new plugs (been there, done that).
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Yes, I checked the plug wiring several times.
I bought the inline ignition tester at Autozone. The cable is too short. It can’t reach the spark plug. I ended up returning it.
The van was running fine before I changed the plugs. I checked the park number on the plugs.
I still don’t know what wrong with it.
 

·
Registered
Joined
·
1 Posts
I am hoping someone can help me with this issue. My van has 140K miles. I replaced 6 spark plugs with Denso Iridium a month ago. Now, the engine is a little shake when driving with 3 lights stayed on (AWD, Engine Check, and Trac Off). My OBDII shows three codes (P0302 P0304 P0306) on bank 2.

What could be the problem? I replaced the ignition coil on cylinder #6 just to test. But the OBDII still showed the same trouble codes(P0302 P0304 P0306).

Thanks
Check and replace the other coils. It took the dealer 3x to get this right with my truck
 
1 - 6 of 6 Posts
Top