Toyota Tundra Forums banner
1 - 12 of 12 Posts

·
Registered
2002 Sequoia SR5 2019 Sequoia Limited
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi
I have a 2002 Sequoia that the A/C compressor won't engage when the A/C switch is pressed. The light comes on when with is pressed. I checked all the fuses and have swapped relays. At the plug at the compressor there is no voltage. I have a 2005 service manual but can't seem to find a good schematic of the wiring for the A/C.
Any help is greatly appreciated.
 

·
Registered
Joined
·
229 Posts
Hi
I have a 2002 Sequoia that the A/C compressor won't engage when the A/C switch is pressed. The light comes on when with is pressed. I checked all the fuses and have swapped relays. At the plug at the compressor there is no voltage. I have a 2005 service manual but can't seem to find a good schematic of the wiring for the A/C.
Any help is greatly appreciated.
Is the AC light blinking? Or does it stay illuminated?
 

·
Registered
Joined
·
244 Posts
Have you put a/c gauges on to see refrigerant pressure is where it should be. There is a pressure switch that will only signal the compressor to kick on if the refrigerant level is where it should be. Years ago (70's) had a p/u that had the same issue and was able to take the power wire from the pressure switch, (I believe that it was at the compressor) and jump it from the positive battery terminal. You should hear the switch click on and off as you apply and remove jumper. With my old truck I just ran those wires to a (lighted) toggle switch I had installed in the dash and when I needed a/c flip the switch. It was still working off of that switch 12 years later when I sold the ruck. I know, it would have been better to replace the switch I guess, but "poor folks got poor folks ways. But using a jumper is is a way to see if the switch is working or not. Chap
 

·
Premium Member
Joined
·
34 Posts
I'll go with low on refrigerant. I doubt the pressure switch is bad, but Chappy's test will prove that.
 

·
Registered
2002 Sequoia SR5 2019 Sequoia Limited
Joined
·
7 Posts
Discussion Starter · #7 · (Edited)
I managed to use a wire from the battery to the connector on the compressor to get the compressor to engage and filled it with refrigerant. Its was a bit of a challenge but I got it done. Thanks for the advice, Chappy!

So now it cools ok, but the little electric fan that is in front of the condenser does not come on when the AC is on. The fan works when powered directly from the battery, so I thought it may be a relay, but that didn't change anything. It's hot today, 97F so I'm pretty sure the fan should be running.

Any ideas?
 

·
Registered
Joined
·
244 Posts
Great news, glad you got it cooling at least. 97F ain't hot it was 113 here in Tucson yesterday... Chap
 

·
Registered
Joined
·
244 Posts
"It's a dry heat" is a slogan that is commonly found on snow bird and tourist "T" Shirts and bumper sticker. Us locals know it as just plain HOT!

Back to charging the a/c unit. With the engine running you can put refrigerant in the system without having to engage the compressor. When the pressure approaches the "kick-on" pressure of the pressure switch the compressor will stutter a bit (on-off) then switch on as you continue to top off the unit. Never thought of jumping it to fill unit. Seems like doing that might speed up the process???

I had a 1952 Ford P/U with a brand new aftermarket a/c system and after the install and a quick "evacuation" of the system, with the engine running, all a/c controls on their coldest settings I started filling the system with refrigerant. It wasn't long until the compressor acted as stated above and then kicked in. I ran the system for 12 years and had to repeat the process only once when I pulled the system to do a rebuild on the old flathead. Great experience and it even kept the cab cold during those periods of Arizona "Dry Heat"... Chap
 

·
Registered
Joined
·
244 Posts
Yep, poor folks, poor ways...The "just make it work" approach. Overall good diagnosis info, Thanks . . . Chap
 
1 - 12 of 12 Posts
Top