Toyota Tundra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
At times I have tried to accelerate, but when i step on the pedal, nothing happens. Dont accelerate, RPMs dont move either. If I instantly take my foot off the pedal and then depress it again, I accelerate. Any thoughts?
 

·
Registered
Joined
·
228 Posts
Please give us your mileage and climate in which the vehicle operates. This is certainly interesting.
 

·
Registered
Joined
·
68 Posts
This is that throttle position sensor problem, right? I've read about that before on here. Like when the problem happens there's some way to mash the pedal all the way to the floor and it will manage to limp home so you're not completely stranded when the TPS craps out. I haven't had the problem but I vaguely recall reading something like this. Search for throttle position sensor and I'll bet you find something.

I suspect the blipping of the throttle is getting the tps to work again temporarily... better get it fixed before it's completely out.
 

·
Registered
Joined
·
228 Posts
Scratching my head here. Search in the Tundra forum as well...same vehicle except we have a permanent cab over our back seats!
 

·
Registered
Joined
·
68 Posts
found many threads for no throttle response. many were dead ends. i think this is the one i was recalling reading that pointed to the accelerator pedal as a common culprit. many threads described people changing throttle bodies and not fixing it. many incorrect diagnosis stories from dealers or mechanics....


it's drive by wire so the sensor in the pedal acts up so the ecm doesn't tell the throttle control motor to move the butterfly. fiddling with the accelerator gets it to work a little. up until it's completely broken and you're stuck.

here's the bad ones. search no throttle response and read up:
https://www.tundrasolutions.com/threads/no-acceleration-on-03-tundra-fried-throttle-sensor.21527/#post-249759

https://www.tundrasolutions.com/threads/2005-tundra-no-throttle-response.204848/#post-1975174

https://www.tundrasolutions.com/threads/throttle-problem.204024/#post-1971028
 

·
Registered
Joined
·
68 Posts
I have a (maybe?) similar thing happen, but I would call it a "pause" before acceleration starts. It happens more on dirt/gravel and when I'm going from a dead stop and making a turn (especially on a hill). It sounds like this might not be your problem, but wanted to chime in so you can rule it out. In my case, it seems like it's traction control preventing acceleration. It's scary and seems like an eternity before acceleration starts. It got much better after replacing sway bar bushings for me, but it's back to where it was now.

Here's a thread: https://www.tundrasolutions.com/threads/hesitation-on-sharp-turns.12844/
 
1 - 8 of 8 Posts
Top