Toyota Tundra Forums banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
63 Posts
Discussion Starter #1
I have an '02 Tundra with a LineX sprayed bed. I have had it for a little over three years and haven't had a lick of trouble with the truck at all!! Got the bed sprayed the day after I got the truck and it has been great.

The last couple days we have had some rain and I have noticed that the bed isn't draining like it always has. It fills with water up by the cab. It runs out inder the tailgate when I take off but it has never pooled like this.

Does anyone have any thoughts or ideas on this?

Thanks......Mike
 

·
Resident Curmudgeon
Joined
·
5,211 Posts
As noted above, drill new drain holes and / or check the old ones.
 

·
Registered
Joined
·
567 Posts
Check the big rubber groments in the front of the bed and see if the drain holes got plugged maybe make them a little bigger, i just leave mine out since i have my atv in the back a lot dripping mud all over the place.

Andrew
 

·
Registered
Joined
·
917 Posts
Mine does the same thing. Never really bothered me. As mentioned above drill a hole in the rubber plugs.
 

·
Resident Curmudgeon
Joined
·
5,211 Posts
Yes. If you don't want to pull them completely out, just cut an X in the rubber. Check them every so often. It shouldn't hurt to drill a couple of smaller holes if you want as well.
 

·
Premium Member
Joined
·
63 Posts
Discussion Starter #9
Thanks for the help guys. Just strange that it has drained great for the last three years but now all of a sudden it won't drain.
 
1 - 9 of 9 Posts
Top