Toyota Tundra Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,094 Posts
Discussion Starter #1
Driving on I-95 yesterday, approx 80 mph and out of no where the truck got sluggish and my traction control light came on, CEL light came on and my VSC off light came on and blinked; I noticed the truck did not have the pep it usually did and when I would hit it the truck would not downshift. Tranny/coolant temps were fine as was the oil pressure.
Got to where I was going and hoped the truck would "reset" itself when it was turned off and it did not. It did feel better after it was off and sat for a little bit, drove it home and the truck was acting normal. Turned it off to put gas in it and the lights went out which left me scratching my head, got home, plugged in my Xcal 3 from my mustang and it pulled code 2121 which is the throttle position sensor....????....the truck is an 07 with 22k on it, I will keep on eye on it but was wondering if anyone else ever had this issue..I go out of warranty next month so if it is something that needs fixed I need to do it now.
 

·
Registered
Joined
·
2,048 Posts
When a CEL/MIL goes on, TC and VSC go into limp mode automatically, that is why you saw them on as well. Sorry I can't help with the CEL/MIL but just wanted to clarify the additional lights.
 

·
Premium Member
Joined
·
5,467 Posts
I can't help with specifics either but the generic description for P2121 is:
"Throttle/Pedal Position Sensor/Switch "D" Circuit Range/Performance"
Did you recently have the recall done??
 

·
Registered
Joined
·
7,461 Posts
if u have warranty left take it in now...of course its something that needs to be fixed...even if it decides to fix itself, (hopefully you did not reset the codes) the dealership needs to document it happened while under warranty so hopefully when it goes tiits up after you are out of warranty you have some argument that it broke back when it was covered....
 

·
Registered
Joined
·
179 Posts
just my 2cents....i have an 07 as well and my warranty will be up in 2 months. but if u plan on keeping the truck, it wouldn't be a bad idea to invest in an extended warranty. you still can because your original warranty isn't up. platinum plan for 8yr/75k costs $749. i plan on buying one soon
 

·
Mark it eight, Dude...
Joined
·
4,373 Posts
Driving on I-95 yesterday, approx 80 mph and out of no where the truck got sluggish and my traction control light came on, CEL light came on and my VSC off light came on and blinked; I noticed the truck did not have the pep it usually did and when I would hit it the truck would not downshift. Tranny/coolant temps were fine as was the oil pressure.
Got to where I was going and hoped the truck would "reset" itself when it was turned off and it did not. It did feel better after it was off and sat for a little bit, drove it home and the truck was acting normal. Turned it off to put gas in it and the lights went out which left me scratching my head, got home, plugged in my Xcal 3 from my mustang and it pulled code 2121 which is the throttle position sensor....????....the truck is an 07 with 22k on it, I will keep on eye on it but was wondering if anyone else ever had this issue..I go out of warranty next month so if it is something that needs fixed I need to do it now.
Go to the dealership ASAP!!! and like Barney said don't reset the codes. This might be a good enough reminder that you should buy an extended warranty before the factory one expires!
 

·
Registered
Joined
·
1,094 Posts
Discussion Starter #7
Oops...sigh..I did re-set the code but hopefully it is still in the memory.

I did not have the recall done as I can't see how sticking a piece of metal in between 2 pieces of plastic is going to help/hurt anything.
 

·
Registered
Joined
·
149 Posts
I am with Greg Hazlet, just had this issue on my way home from work and it could of ended up badly. I was in the middle of a left turn when the throttle position sensor decided to go hay wire....just as i started and committed to the turn the dash lit up (check engine, vsc, etc) and engine "idled" up to 1300ish RPM's which was the max speed it would go...accelerator floored with no change...

Luckily the vehciles approaching were far enough back that they slowed for me making my 3mph left turn to which I had to activate hazards cause it took so long. Makes me pretty angry cause i bought my toyota not to have problems and the Tundra's seem to be racking up some significant ones(airinduction pump).

Anyway took it to AutoZone right before it closed and they pulled the same code, TPS. Throttle Position Sensor was the only listed problem for that given code for toyota as some codes list multiple possible causes.

Just had whole pedal assembly replaced a week or two ago, so hopefully whatever the problem the stealership honors it under the powertrain warranty as I have 40xxx miles or as a issue possibly created from replacement of the whole pedal(not sure...maybe accelerator position sensor prob)...

Anyways, I will post results of what dealer says. I did not reset the code, so it will be there for em..and I will let em know just how upset I am as the problem could of resulted in an accident.
 

·
Mark it eight, Dude...
Joined
·
4,373 Posts
I am with Greg Hazlet, just had this issue on my way home from work and it could of ended up badly. I was in the middle of a left turn when the throttle position sensor decided to go hay wire....just as i started and committed to the turn the dash lit up (check engine, vsc, etc) and engine "idled" up to 1300ish RPM's which was the max speed it would go...accelerator floored with no change...

Luckily the vehciles approaching were far enough back that they slowed for me making my 3mph left turn to which I had to activate hazards cause it took so long. Makes me pretty angry cause i bought my toyota not to have problems and the Tundra's seem to be racking up some significant ones(airinduction pump).

Anyway took it to AutoZone right before it closed and they pulled the same code, TPS. Throttle Position Sensor was the only listed problem for that given code for toyota as some codes list multiple possible causes.

Just had whole pedal assembly replaced a week or two ago, so hopefully whatever the problem the stealership honors it under the powertrain warranty as I have 40xxx miles or as a issue possibly created from replacement of the whole pedal(not sure...maybe accelerator position sensor prob)...

Anyways, I will post results of what dealer says. I did not reset the code, so it will be there for em..and I will let em know just how upset I am as the problem could of resulted in an accident.
I think that toyota will have a problem with lawsuits eventually because of this "limp mode". It just sucks that it will probably take a few deaths before they address this. Scares me to think that something like this could happen to me with my family in the truck. Sorry guys, report back when you get it all figured out.
 

·
Registered
Joined
·
149 Posts
This is what had me so concerned, angry, and upset! I work in the area for a local law enforcement agency and the problem occured in the most unsafe intersection in the state(due to accidents and fatalities over the prior year) and I alone have been on quite a handful of both serious injury and fatal accidents at the listed intersection while working. We'll see, I am taking truck to dealer first thing in morning, so hopefully I will have results!



I think that toyota will have a problem with lawsuits eventually because of this "limp mode". It just sucks that it will probably take a few deaths before they address this. Scares me to think that something like this could happen to me with my family in the truck. Sorry guys, report back when you get it all figured out.
 

·
Registered
Joined
·
1,094 Posts
Discussion Starter #11
My truck goes in next Friday for the about to go out of warranty list of stuff to fix and this is one of them; let me know what you find out and I will do the same.
 

·
Registered
Joined
·
1,094 Posts
Discussion Starter #12
Since you and I both have Unichips I hope that had nothing to do with it...
 

·
Registered
Joined
·
149 Posts
Well brought truck to the dealer today with the TPS problem and left in a loaner Toyota Camry. They said they were stumped and have not seen the problem and did bring up the air induction pump as a possible issue but said it was not as no related codes for it came up.

They said it was an all day project(left it there while went to work) and they called up the toyota reps/engineers for troubleshooting. In the end they stated it needs a new throttle body as the throttle position sensor is built in to the whole unit. 1200.00 for a new TB, ouch, and they said it is not covered under the Powertrain warranty for some odd reason? Im still trying to figure that one out, but anyways dealer said they would honor the PT warranty and replace it for free cause it didnt make much sense.

They did not mention anything about my Unichip or Throttle body coolant bypass so IM going to assume that the mods were not responsible for the problem, and my service advisor is aware of all my mods.

They did recreate the problem in test drive where it lost all power and gave me the loaner as they did not want me crashing. So all in all I am kinda happy, just afraid once I get it back it will happen again shortly!? Makes me consider even more of selling it privately and putting it back to stock to get my Lexus IS-F(used of course,to much new), 2011 Subura STI, or new 5-0 mustang!

Anyways will keep all posted of the results...
 

·
Registered
Joined
·
1,094 Posts
Discussion Starter #14
Interesting...hmm...I have found the truck "stumble" since I had that code pop but it fixes itself right away and the code has not come back....
 
1 - 14 of 14 Posts
Top