Toyota Tundra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have an '08 Sequoia with about 150K miles on the 5.7L.

Took the family out for ice cream tonight and noticed that none of my gauges are working except the fuel gauge. Also, none of the MPG info is being displayed and my temp gauge stopped working. Also, power steering, brakes, air bag and ABS warning lights are illuminated.

I checked all of (what seem to be) the right fuses - MET and MET B under the hood and cluster fuse in the cabin and they're all good (even swapped a couple around to be sure).

I disconnected the battery for about 15 minutes to reset the computer.

No dice. Gauges are still not working.

Before I go to the dealership, is there anything else I should try?

Was thinking of cleaning the ground connections, but I'm not sure where they are. Can anyone give me direction on where to find them?

Thanks for helping a newbie out.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Diagnosis: bad combination meter. It controls nearly all the sensors in the dash including the odometer. That means not only do you have to pay for the part, you have to pay for another outfit to set it to the right mileage.

I'll post an update once it's installed.
 

·
Registered
Joined
·
12 Posts
I have an '08 Sequoia with about 150K miles on the 5.7L.

Took the family out for ice cream tonight and noticed that none of my gauges are working except the fuel gauge. Also, none of the MPG info is being displayed and my temp gauge stopped working. Also, power steering, brakes, air bag and ABS warning lights are illuminated.

I checked all of (what seem to be) the right fuses - MET and MET B under the hood and cluster fuse in the cabin and they're all good (even swapped a couple around to be sure).

I disconnected the battery for about 15 minutes to reset the computer.

No dice. Gauges are still not working.

Before I go to the dealership, is there anything else I should try?

Was thinking of cleaning the ground connections, but I'm not sure where they are. Can anyone give me direction on where to find them?

Thanks for helping a newbie out.
Hello I'm new to the forum, my truck is having the same problem any pointers?
 
1 - 4 of 4 Posts
Top