Toyota Tundra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hello,

Can anyone help with advice on this?

2003 Toyota Tundra shuts off or stalls in drive/reverse gears when at a stop only. Will go with fast acceleration.
-No signs of transmission issue prior
-only code is catalytic converter below threshold
-Replaced throttle body after problem. No luck.
-Replaced air filter 30k miles back
-replaced spark plugs 20k miles back

Could this be the fuel pump or related part?

Thanks,
Alan
 

·
Registered
Joined
·
3,287 Posts
Isnt catalytic below threshold usually related to 02 sensors? Post what the actual code is on here and you might get some offering suggestions.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The code is P0420 catalyst system efficiency below threshold bank 1. It has been on there for a few years prior to this breakdown.
 

·
Registered
Joined
·
3,287 Posts
Maybe start with the code you know you have first. A quick search on here says you need new 02 sensors and stick with only Denso, never Bosch. If it were me I would replace those and see if that takes care of it. Here's one:



If you replace the sensors and still have problems then read this one. Not saying you have the same issue as symptoms are different but the point is this guy had damaged wires due to mice so you might have a similar problem. And shorted wires can cause all kinds of weird issues.

 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thanks. I'm going to try removing the driver's side converter and looking at it and then that as well.
 
1 - 5 of 5 Posts
Top