Toyota Tundra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
My gas gauge started acting up a few month ago, can anyone help me narrow down what this could be? It works from 3/4 to full and empty to 1/2 but for some reason from 3/4 down to 1/2 it's dropping to completely empty and back up. My guess is it's a loose electrical connection but i have checked and can't find one, thoughts?

CMill
 

·
Professional Driver
Joined
·
501 Posts
If it works in the same areas consistantly, It is most likely the sending unit in the tank. If it is the sending unit, I doubt it will be a cheap fix. It is not too common for a sending unit to go bad on an '03, though, but your description sure makes it sound like it is.
 

·
ΜΟΛΩΝ ΛΑΒ&
Joined
·
1,613 Posts
yeah, mine started doing that about a year ago. I just learned to live with it since I figure it was the sending unit that wouldn't be cheap to fix. I use the trip meter mostly now for gas monitoring anywho.
 

·
Registered
Joined
·
56 Posts
Mine does the same thing, I pulled the tank down to try to figure it out, tested the sending unit and what not all was good.

What I did manage to do was break the filler neck above the tank which caused the dreaded "check engine light" to come on.

I brought it in and they wanted 400 to fix it, it's not that hard oa job, just a slow one so I will be doing that myself.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #6 ·
I'll pull the tank this weekend then, I was hoping not to have to but oh well. Thanks for the help!

CMill
 
1 - 6 of 6 Posts
Top