Toyota Tundra Forums banner
1 - 20 of 43 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
i have a 07 tundra 5.7 with 35000 miles and i have had rear axel bearings fixed and now they are replacing some kind of canister that made engine light come on that is it.

what repairs have you had to do to your tundra ?
 

·
Premium Member
Joined
·
846 Posts
I had my evap canister replaced at around 10k. it two caused a CEL and they thought it was the gas cap. Also my rear end was replaced at 28k. Debris in rear end frmm failure causing more damage.
 

·
Premium Member
Joined
·
717 Posts
07 Double cab, TRD package and Ive had zero work done on it and Im @ 45,000 miles currently.
 

·
Registered
Joined
·
7,461 Posts
dont we have like a bazillion threads like this already?

oh well...

07 DC, bought april 07, 43k miles, been in for one warranty claim- the tailgate handle had a plastic clip break and the rod came off so it would not open. thats it.
 

·
Registered
Joined
·
63 Posts
Rolled over 50,000 last week with no warranty problems what so ever!
 

·
Registered
Joined
·
859 Posts
15k. No issues whatsoever. I keep having to fill it with gas though......
 

·
Registered
Joined
·
2,669 Posts
Had the front diff TSB wuwuwu thingy fixed.............that's it.
 

·
Registered
Joined
·
40 Posts
09 Crewmax 4x4 5.7. Purchased 3/29/2009. About 12,400 miles as of today. Zero problems so far, not a single hiccup. OK I'll admit I get a slight, occasional 'nibble' in the steering wheel when braking at certain speeds indicating a rotor issue. But having studied that for awhile I know it's a common low mileage problem in half tons now and corrosion of brake linings caused by lack of use can be a contributing factor. It hasn't set in for good yet so I'm not worried about it for now. If it does I'll go with aftermarket stuff I've had good luck with in the past rather than raising a fuss at the dealership so they'll replace it with OEM stuff that'll just have me in there again next year.

Not a single hiccup from the engine, tranny or any other part of the truck. The passenger side of my dash by my measure sits about 1/8 to 1/4 inch lower than the driver's side edge. Can't figure out if this is the infamous 'sinking dash' issue but nothing will be done about it unless/until it gets worse.

It has had the accelerator pedal recall which I now regret... it worked fine before, now it's 'JUMPY' and I'll likely have to ask for a new pedal to replace the 'ghetto shim' at my next oil change.

At this rate I'll probly have about 20K at the two year mark but won't even hit 30K by the third year. It sometimes sits for days at a time, and wouldn't have this much if I hadn't taken a road trip and put it to what will come to be considered an abnormal amount of use in the first six months of ownership.
 

·
Registered
Joined
·
1,685 Posts
50K just had a rubber drip moulding replaced on the roof because it came off in a carwash dry cycle. Other than that, ZERO PROBLEMS.


And try searching before starting a thread.
 

·
Registered
Joined
·
197 Posts
22,000 miles. Squeaky front driver, passenger windows when raised or lowered, front rotors / pads replaced, new gas pedal, serpentine belt & idle tensioner replaced, drivers side AC vent would not hold position ( parts ordered the replacement I asked the clerk if I could compare the new part to the old and popped it in right in front of him after service manager told me it was a 2 to 3 hour job to open the dash, took me 10 seconds to install) .

Guess when the Toyota CEO said a few years ago he wanted a 30% reduction in costs he meant dumbing down the quality.
 

·
Premium Member
Joined
·
5,472 Posts
47,000 with no significant repairs. Just the stock radio head replaced under warranty.
 

·
Registered
Joined
·
133 Posts
07 Crewmax 4x4 TRD 43K miles

New rotors and brakes
New radio
Serpentine belt (squeal at startup)
Center console cover (upholstery problem)
Chrome lug nuts are super rusty (I'm going to order a new set on ebay)

As stated before; biggest problem.... I have to keep filling it up with gas.

Nothing major but not bulletproof.
 

·
Registered
Joined
·
4,519 Posts
42k on my truck currently. Front diff, sinking dash(still not fixed properly will have to do it myself), rusty front and back bumpers replaced, now have drivetrain slack(bump from behind, not going to address it at this point). Oh yeah, broken lug nut(my own fault).
 

·
Registered
Joined
·
148 Posts
75,000 miles here and 3 years of ownership

-Front diff replaced at 34k
-Serp belt and Tensioner at 45k

Pretty solid for a first model year vehicle. I don't baby it either, I drive it like I stole it
 

·
Registered
Joined
·
195 Posts
51,000 replaced brake rotors (now warped again), serpentine belt, 2 set´s of tires, 1 rear light bulb - so basically nothing broke, this is all considered wear and tear items. To catch any problems early, I have my truck checked and inspected every 5k miles while doing oil change at the dealer since we rely on this vehicle a lot and can not affort to be stranded in the Bronx or a PA snowstorm.
 

·
Registered
Joined
·
1,539 Posts
My '07 Tundra that I owned from April 2007 to May 2010 had the following issues...

- Front passenger side wheel bearing replaced.

- Front differential replaced twice, 3rd one still had a vibration.
http://www.tundrasolutions.com/forums/tundra/117211-humming-sound-update-need-your-thoughts/
http://www.tundrasolutions.com/forums/tundra/147575-vibration-woes-continue/

- Water pump replaced due to leaking.

- Windshield cowling replaced due to warping

- Window trim on driver door replaced.

- Annoying rattle behind the dash which never got resolved.

- Tailgate replaced due to cracking at seams.

- Rear bumper replaced due to rust from poor chrome plating (new bumper was fine).
http://www.tundrasolutions.com/forums/tundra/157511-got-my-replacement-rear-bumper/

- All 20 lug nuts replaced twice due to rusting. Third set still rusted.
http://www.tundrasolutions.com/forums/tundra/153310-lug-nuts-rusting-again/

- Always had a resonance/vibration in steering, pedals and floor. Dealer looked at it a few times but never figured it out. Was then told it was "normal".
http://www.tundrasolutions.com/forums/tundra/124977-is-this-exhaust-drone/

- Loud screech when starting the truck in the winter. Never got resolved even after replacing the tensioner pulley and serpentine belt.
http://www.tundrasolutions.com/forums/tundra/153787-squeal-at-startup/

- Excessive undercarriage rust.
http://www.tundrasolutions.com/foru...ior/135892-sprayed-rustproofing-on-rear-axle/
 
1 - 20 of 43 Posts
Top