Toyota Tundra Forums banner

1 - 7 of 7 Posts

·
Banned
Joined
·
13 Posts
Discussion Starter #1
After installing a new battery my check engine light came on, It's a 98 4 runner 4 cyl. 2 w/d automatic, Can anyone tell me how to shut it off. I checked all the codes and nothing comes up with a problem.
Thanks in advance.
 

·
Banned
Joined
·
13 Posts
Discussion Starter #3
I went to autozone they said all the codes came up ok, But he told me to take it to toyota to get the light turned off, I remmember in one of my last toyota's I could turn on the key pump the gas peddle a few times then turn off the key and then re start the truck and the light would be off, But I can't remember how many times to pump the gas or if that will even work with this 4 runner.
 

·
Registered
Joined
·
4 Posts
You can turn the light off by disconnecting the battery again or removing and re-seating the EFI fuse (IIRC).
 

·
Banned
Joined
·
13 Posts
Discussion Starter #5
A man thanks a lot, I'll give it a try, After putting the rear end in I can't afford taking it to a shop.
 

·
Banned
Joined
·
13 Posts
Discussion Starter #6
Thanks 98tacoma27, I disconed the battery waited about 5 minutes and hooked it back, And I'll be darn no more engine light.
Thanks again
DC2006
 

·
Banned
Joined
·
13 Posts
Discussion Starter #7
OOPs disconnecting the battery and reconnecting it worked for about 2 days and the check engine light is back on, I'm going to try removing and re-seating the EFI fuse (IIRC). now and see what happens, I'm keeping my fingers crossed. Update to follow. Normally that light is due to a smog equipment problem right?
 
1 - 7 of 7 Posts
Top