Toyota Tundra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I just bought an 02 Sequoia 2wd with 105k miles on it. I plan on getting the T-belt, waterpump and belts changed ASAP. Any other recomendations? Also- the rear window does not work with the switch or the remote. I plan to use the truck to tow my utility trailer from time to time also so I am looking for information on installing a 7 pin trailer adapter- I already have the factory hitch with the 4 pin. This forum looks really helpful with alot of good information. Thanks for any suggestions.
 

·
Premium Member
Joined
·
695 Posts
Hello, I just bought an 02 Sequoia 2wd with 105k miles on it. I plan on getting the T-belt, waterpump and belts changed ASAP. Any other recomendations? Also- the rear window does not work with the switch or the remote. I plan to use the truck to tow my utility trailer from time to time also so I am looking for information on installing a 7 pin trailer adapter- I already have the factory hitch with the 4 pin. This forum looks really helpful with alot of good information. Thanks for any suggestions.
Hey there, GOOD LUCK with your new truck!!!:tu: As far as the info on the trailer adapter you should have no problem at all finding that info. Just do a search, I know I have seen it so many times on this web site. Don't just look in the Sequoia forum for it, not that you won't but it will be the same wireing as the Tundra and I might have seen that info in that forum. As far as your rear window motor not working I remember reading a thread about that a few months back and I went and found that one for you. There's ALOT of great info in that thread, check it out for yourself by clicking here: http://www.tundrasolutions.com/forums/sequoia/66408-rear-window-stopped-working/. Let us know how you make out. Injoy your new truck!!:tu: Johnnnny :D
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the help and thread on the rear window. I can't wait to take it apart this weekend and try and fix it. Have a good one! --Steve
 
1 - 3 of 3 Posts
Top