Toyota Tundra Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,
The other day I had the check engine light come on along with a severe loss of power/acceleration. When I accelerated up a hill the rpms would not go above 3500 and the further I depressed the pedal the less power. I tried switching to manual shift but it didn't make any difference. I limped into a station and they gauged me and told me my air filter was dirty. They have to order a new one but took me out for a test without the air filter and ran great- 5.7 liters doing their thing. Left the station with no check engine light. Ordered a new air filter, to be here next week.

So, today, engine light is back and same symptoms, power loss, won't accelerate, no climbing above 4000rpms. The thing is- there's no air filter so it can't be that.

I unhooked the battery to reset the engine code, and voila, no light and no loss of power.

I live in Mexico so the more information I can offer my mechanic the better.

Can anyone help me with some ideas? Love my truck, want it back to full power.

Thanks!
 

·
Premium Member
Joined
·
5,472 Posts
Was it just the Check Engine light, or were there other lights on also?
That sounds like "limp mode". The most common cause is an AIP valve failure but that normally flashes the VSC light also.
Maybe this will help you:
lights.pdf
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks, Mendonsy- that is a great resource. It is just the check engine light- although the tire pressure has been intermittent but don't see a code for those two together. Looks like I'll be contacting Paul...!
 

·
Premium Member
Joined
·
5,472 Posts
Paul's AIP kit will probably save you problems in the future, but I'm not entirely sure it will solve your immediate problem.
You should at least get the DTC's scanned to see what that tells you. It could be something as simple as a loose gas cap.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Well, I have the dreaded p0418 plus the p2445. What should my next steps be? Unhooked the battery and am out of limp mode. No CEL. Is this my next step?

"AIP Solution: Disconnect both air pumps. You will get a CEL ( Codes P0418,P0419)but no limp mode and no affect on performance. AIP system will be shut down preventing valves from opening. There are two pump connectors, one behind the coolant reservoir on the front of the engine and one below the air box along the wheel well. Both are large gray connectors. Disconnect them, tape them up, zip tie them to keep them from getting into anything hot or moving and your done. If you need service done, reconnect them before you take the truck to the dealer. Enjoy."
 

·
Premium Member
Joined
·
5,472 Posts
There is a 10yr/150k mile warranty on the AIP system. Get it repaired by a dealer then install Paul's AIP bypass kit to keep it from happening again.
 

·
Registered
Joined
·
21 Posts
I had the very same problem 5-8-2014 vsc blinking light,check engine light on traction control blinking, loss of power, came home looked up the problem on here and waa laa, I disconnected my negative battery terminal and reset the codes by doing so and it cleared the lights, thanks guys if it happens again i'll leave it alone and drive to the dealer to get it fixed
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top