Toyota Tundra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello everyone. I am looking for help in trying to diagnose a loud roar on my 2004 Sequioa. I was driving on the highway during a very windy day. When I reached around 75 to 80 mph a very loud roar came from the front right section of the vehicle. I thought I had blown out a tire and slowed and stopped on the side of the road. I got out and looked and tires were fine. I started out again and when I reach around 75, it happened again. I slowed and it went away. When I got home, I got under the truck and looked and everything looked fine. It has happened once more last week. Only seems to happen when it is very windy. Has anyone else experienced this. Any help appreciated. Thanks.
 

·
Registered
Joined
·
5 Posts
Sounds like you may have a front wheel bearing going bad. I had the same thing happen to me before and I wouldn't hear anything until certain speeds. It eventually got worse and I would hear it while going around curves. It took me forever to find the problem. I replaced the CV joints, pads, rotor, etc. trying to find it. Eventually the wheel bearing was all that was left and sure enough, that was the problem.

Then again you could have one of those faulty ball joints that Toyota made a recall on....just a thought.
 

·
Registered
Joined
·
191 Posts
do you have a front wind / rock deflector? - It could be vibrating - mine did it until I figured out that I had lost one of the clips - got a new clip & all is good now
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks for the reply, guys. I don't think its a bearing but I will keep an eye on that. When you mentioned, Celica, a front wind / rock deflector it made me think that there are some plastic deflectors in front of the wheels. I will look at that to see if they are loose in any way. Thanks again for the ideas.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Just to close the loop; I believe that the sunroof wind deflector on top is what has been causing the noise. New one ordered. We shall see.
 

·
Registered
Joined
·
13 Posts
hey, i have a roaring noise too just like you and i thought forever that it was also coming from the right front passenger side. when someone else was driving, i snooped around and i found out that it was actually coming from the sunroof!

but i don't have a wind deflector on there and the seal around the moonroof looked new to me. any ideas? how is your new wind deflector working?

this roaring/howling noise makes the suv sound like it's in bad shape when in fact i have 150k miles with no problems!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Taxidriver,
I ordered the wind deflector but it has not come in yet. That roar does sound like it's coming from the right front passenger side. I hope the deflector fixes it. Maybe you should install the sun room wind deflector and see if it fixes yours. I will post whenever I get the thing installed.
 
1 - 8 of 8 Posts
Top