Toyota Tundra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
609 Posts
Discussion Starter · #1 ·
Under hard acceleration (like 20-50 mph) I hear multiple metalic pinging type of sounds from under the hood. Did anybody experinced the same?
 

·
Registered
Joined
·
207 Posts
most typically this is from using too low an octane of gas resulting in incomplete detonation or "pinging" try gas at a different station or move up a grade of gas. Other causes could be poorly adjusted lifters, exhaust leaks etc.
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #4 ·
I think most likely it is the gas, at least sounds that way. I am using Mobil or SUnoco 87 octane. Since I drive about 200 miles a day moving up to 89 octane is not a good solution, however I will give it a try for a week (that will be 5 tankfulls :( )

:D
 

·
Supportive Supporter
Joined
·
1,142 Posts
You could also go to autozone ( or some shop like that ) and check your codes.....maybe you have a pending code (meaning it's not quite bad enuf to throw a CEL ) on a O2 or temp sensor...hey.....that's cheaper than gas! And since I drive 130 miles everyday.....I feel your pain! :D
 

·
Registered
Joined
·
379 Posts
that definitely sounds like detonation. if that is the case, i would first try a "good" brand of gasoline, like chevron 87 octane. if the problem continues, move up to 89 octane. if that solves the problem, stick with that. you'll save more money in the long run by preventing damage to your engine.
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #7 ·
I usualy get Mobil (not because I like them but it is convenient and the cheapest major brand on my road). Just switched over to 89 octane today, will see what happens.
 
1 - 8 of 8 Posts
Top