Toyota Tundra Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I switched jobs last year and finally got the truck that I wanted for years...2012 Crewmax Rock Warrior. It's a truck and you don't expect a super quiet luxury ride, but at least the comfort of no strange noises of an old used car. About a year in, a strange rattle and knocking was coming from the engine compartment every time I hit a bump. I dropped it to the dealer 2 times, the second time they had my truck for a week. Both times they said they fixed it but as I pulled out of the lot, I could hear it the minute I hit the first bump in the road....I was bitter to say the least. The first time they claimed it to be the hood bumpers, the second time a "pebble on the rock shield." (I pebble doesn't make this kind of noise) After reading forums here then tearing the front of my truck and the interior dash, I finally found the culprit. The bracket that was holding my radiator in was loose and it was rattling. I don't know how the noise sounded like it was coming closer to the dash...but I figure if anyone has a random noise...keep that in mind. I loosened the two top bolts up and had to actually bend the bracket to have a more snug fit...problem solved.


Anyway...wanted to share the story in case anyone has a mystery clunk...Everything out there has pointed it to the exhaust, wiring under passenger dash, wheel well, chassis bolts...now I can add the radiator bracket to the mix.
 

· Premium Member
Joined
·
194 Posts
I hate rattles. Thanks for the post!
 

· Registered
Joined
·
365 Posts
I had the exact same issue and I took mine in twice as well. The second time a tech rode with me and I pointed out the knoise. He found it right then and there. Mine wasn't seated all the way and he seated it, sprayed some kind of lubricant on it, and it hasn't bothered me since. I have about 22,xxx miles on it since this issue was fixed and haven't had any recurrences. I wasn't an active member on here so I didn't post my findings. Thanks for puting this out there.
 

· Registered
Joined
·
1,410 Posts
Good to know if a strange noise ever developes. Thanks for posting.
 

· Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Do you know what they ended up spraying down to fix the problem? I've only "fixed" it 2 weeks ago now, but it hasn't come back. I've got about 20k miles on the car and just waiting to hear it come back and find out it may have been something else. I wish my dealer would have been that much of a help...the one thing they did that I appreciated was give me a free rental for the week.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top