Toyota Tundra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
'05 Tundra 4.7L threw code P0156. I replaced the Bank 2 Sensor 2 with a new Denso and did a reset. Code threw again. Is there a chance that the new sensor was faulty? The voltage tends to stay high (.8-.9)on that sensor while in operation. I say tends because it does not fluctuate as much when compared to B1S2. I have checked connections locally at the sensor and all seems clean and snug. Thoughts or comments greatly appreciated.
 

·
Registered
Joined
·
30 Posts
My 2000 4.7L Tundra got the same code a few weeks ago, I replaced that O2 sensor and within 50 miles got the code for the sensor on the opposite side (can't remember that code # at the moment). I found it hard to believe that they both went so closely together, but after replacing the second one all is good now.

Just thought I'd toss this out in case you might be looking at the same thing. Good luck.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the comments jdub01. Well, I have elimated the thought of a "fault" new Denso part. I swapped both Banks Sensor 2's to see if the problem/code followed. After the swap I cleared my code. After 3 runs about 50 miles the same P0156 code flased. I believe it is either a loose connection or possibly the Bank 2 Sensor 1 being the issue. I read in some older post that Sensor 1 could cause the #2 sensor to throw a code. I'll post after the next find or repair.
 

·
Registered
Joined
·
5 Posts
Trying to get clear info. Don't mean to hijack your thread. I have code p0155. I believe it is bank 2/sensor1. Am I correct that it is the passenger side "before" sensor?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Trying to get clear info. Don't mean to hijack your thread. I have code p0155. I believe it is bank 2/sensor1. Am I correct that it is the passenger side "before" sensor?
Yes that is correct. Passenger side sensor before the CAT.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
The Bank 2 Sensor 1 replacement corrected the issue and code. Odd that the sensor 1 can cause a malfunction code for sensor 2.
 

·
Moderator
2015 Toyota Tundra DC SR5 5.7L
Joined
·
8,537 Posts
The Bank 2 Sensor 1 replacement corrected the issue and code. Odd that the sensor 1 can cause a malfunction code for sensor 2.
They work together. Remember, they are very sensitive to voltage, so I've seen a bad negative ground screw up O2 sensor readings.

Glad you got it figured out.
 
1 - 7 of 7 Posts
Top