Toyota Tundra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have the 2007 SR5 4WD.
The cats on both sides were stolen before, I putted the universal cats with the Denso sensors on it. It was running fine for over 20k miles already.
The code P0430 pop up few months ago, then the light would turn off by itself after a while, then come and go few time. Now stay on, I didn't know if it's up stream or down stream sensor. So I switched the down stream O2 sensors on the cat between driver and passenger side. I reset the light, but the same code P0430 come back again.
I believe it's not the downstream sensor. I am thinking to change the upstream senor.
Any one can give me the part number or link for the passenger side upstream o2 sensor?
Thanks
 

·
Registered
Joined
·
745 Posts
P0430 is Catalyst System Efficiency Below Threshold (Bank 2). It involves both the upstream A/F O2 Sensor and the downstream O2 sensor.
It could be the upstream sensor but I would almost be willing to bet your aftermarket cat may be the problem or you have an exhaust leak that has developed.
Checking for any exhaust leaks between the two sensors and then replacing both sensor is where I would though.
Easiest way to get the part number is to go on something like toyotaparts deal and look it up or call your local toyota dealer then use the part number to buy online.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the information,
Since the upstream sensor is still Toyota part from factory, only with 100k miles. So, I was thinking the cat issue as well. The OEM just cost arm and leg, so i am still thinking after market. I saw some listings on eBay, that custom make directly fit. It's from Canada, free shipping..
I was wondering if anyone had it before.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
yhangout
Toyota Tundra Forums
Tundra Solutions Forum - the best community to talk, mods, price, repair and research your Toyota!
Full Forum Listing
Top