Toyota Tundra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
2004 Toyota 4 runner. Check engine light came on with SVC track off and ob light. The codes scanned are P0441, P0446 and P0455. Any help apreciated. :cry:
 

·
Premium Member
Joined
·
754 Posts
Those are emissions related codes. Most likely you didn't tighten your gas cap. I would fill up again, make sure the cap it turned until it clicks and stop by a autoparts store and have them clear the code (or you could pull the EFI fuse for 10 seconds.)
 

·
Registered
Joined
·
38 Posts
I have an '03 4 runner with the v8, Got a CEL going wich I have already pulled codes from. A delaer told me the same thing about pulling the EFI fuse in order to reset the lights. He told me to pull the efi fuse, Turn on the ignition for about 15 seconds, then put the fuse back in. It never seems to work to reset the CEL. Disconnecting the battery works but it is such a pain. WHat is the correct procedure for the EFI fuse technique? Thanks.
 

·
Premium Member
Joined
·
754 Posts
The easiest way is to go to autozone and have them clear the codes. Anytime they read them, they can clear them.
 

·
Registered
Joined
·
38 Posts
Here we are a few months later and I have determined that the codes are being caused by bad 02 sensors. I bought a new in dash dvd player so there goes the money I was saving for the Sensors, haha. Anyway, I finally resorted to a quick disconnect on my battery. When the codes pop up I simply use the quick disconnect to reset the codes for a few days. Since I know now that it is the 02 sensors at fault I am not overly worried about getting them fixed that soon.
 

·
Registered
Joined
·
5 Posts
Hello a77boy,
I was curious if your O2 sensor replacement was successful in clearing the codes? I just popped the same three generic codes and am considering replacement. Thanks in advance for any info!
 
1 - 6 of 6 Posts
Top