Toyota Tundra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
When I removed the negative lead on my battery to do my install, I had a few problems pop up, anyone have any ideas? My clock will not hold the time, it sets itself to 1:00 every time I turn on the truck. The other problem is that my airbag light on the cluster is constantly on. Thanks in advance for any help.
 

·
Registered
Joined
·
12 Posts
umm try resetting it again by disconnecting the battery for a couple minutes then go again

I don't know about the clock, but for the airbag light:

Turn the key to on, make sure the odometer display is on the odometer, not trip A or B.

Turn truck off.

Hold down the odometer reset button.

Turn the key back to the ON position.

Continue to hold down the reset button until all the little bars go away.

Turn truck back off.

Turn key forward to ON again, once all the idiot lights go off, the air bag light should be off as well.

-worked on my truck when this happened. clock was never affected though.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #4 ·
I don't know about the clock, but for the airbag light:

Turn the key to on, make sure the odometer display is on the odometer, not trip A or B.

Turn truck off.

Hold down the odometer reset button.

Turn the key back to the ON position.

Continue to hold down the reset button until all the little bars go away.

Turn truck back off.

Turn key forward to ON again, once all the idiot lights go off, the air bag light should be off as well.

-worked on my truck when this happened. clock was never affected though.
Cool, that worked, the clock was my fault, I'm retarded and didn't get that plug on the dash completely seated and it was popping loose. It's all good at this point, at least until my new mirror gets here.
 
1 - 4 of 4 Posts
Top