Toyota Tundra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Is it normal when you get to a full stop that the automatic transmission shifts into neutral, well not exactly neutral but if you take your foot of the brake the truck will barely move.

I noticed this because I changed the ATF 3 days ago, I put the type T-IV that says in the manual and checked the level when hot so this is not the problem, if there is any.

Please post your experiences.

I have a 2003 Tacoma Pre-runnner, 3.4 V6, automatic transmission
 

·
Registered
Joined
·
8 Posts
i just did mine last week (00 taco) and used regular dextrose 3 mercon atf from riebes. it took just under 2.5 quarts (we didn't flush it completely). my truck doesn't take off a whole lot when i let off the brake, but it definitely starts pulling (about 2mph maybe). you're probably okay.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
I drainned about 4.2 quarts (4 Lt) from my automatic transmission, the users manual says 2.1 quarts but I've read in a couple of web sites that it's an error, what have been you experience in 2003-2004 automatic V6 tacoma?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Tomgartin, I hope you put Dexron on your automatic transmission, not dextrose (wich is a form of glucose)... :D
 

·
Registered
Joined
·
229 Posts
My 01 doesnt shift to nec but it does feel like it comes out of gear, but it should be okay my truck has done it forever
 
1 - 6 of 6 Posts
Top