Toyota Tundra Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Yesterday the OEM radio in our 2001 Sequoia developed a problem. When the ignition is turned on with the radio off, the LCD display shows all elements on. When the radio is turned all the LCD display elements are still on, but the specific display for the mode it's in (say, FM mode) shows those elements for the radio station a little darker.

Anyone seen this problem before and knows how to fix it?

Unless someone has seen this and knows a quick solution, I'm thinking I'll need to replace this stock unit. I'll be searching the forums at that point to find a suitable replacement. Suggestions along this line are welcome, too.
 

·
Premium Member
Joined
·
695 Posts
Yesterday the OEM radio in our 2001 Sequoia developed a problem. When the ignition is turned on with the radio off, the LCD display shows all elements on. When the radio is turned all the LCD display elements are still on, but the specific display for the mode it's in (say, FM mode) shows those elements for the radio station a little darker.

Anyone seen this problem before and knows how to fix it?

Unless someone has seen this and knows a quick solution, I'm thinking I'll need to replace this stock unit. I'll be searching the forums at that point to find a suitable replacement. Suggestions along this line are welcome, too.
Here's my suggestion for a replacement for you, check it out by clicking here:Pioneer Electronics - Sound. Vision. Soul. You can beet it for the price and it will do a hell of a lot more then what you have now. Once those factory units start to go it's not worth trying to fix them. Just my opinion, Johnnnnny
 
1 - 2 of 2 Posts
Top