Toyota Tundra Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My 05 tundra has 88k miles on it. I have noticed it is starting to idol rough. Any suggestions?
Also, when i first start it up and go to pull out i get a....what feels like a rumble or shake in the rear........only when i first start and pull out.....after that I don't notice it.
 

·
Registered
Joined
·
3,510 Posts
I would try a spark plug change and a Throttle Body cleaning along with some premium gasoline? I changed my plugs at 50K and could tell a big difference in idol being smoother!
 

·
Super Moderator
2015 Toyota Tundra DC SR5 5.7L
Joined
·
8,562 Posts
My 05 tundra has 88k miles on it. I have noticed it is starting to idol rough. Any suggestions?
1. Inspect/replace spark plugs
2. Clean throttle body
3. Clean MAF sensor

Also, when i first start it up and go to pull out i get a....what feels like a rumble or shake in the rear........only when i first start and pull out.....after that I don't notice it.
Rear diff maybe? Check fluid level. If it's been 30,000+ miles, drain/fill.
 

·
Registered
Joined
·
1,071 Posts
You have been watching way too much TV, especially the show called American IDOL

Your truck needs the IDLE checked.
 

·
Premium Member
Joined
·
7,925 Posts

·
Registered
Joined
·
1 Posts
I too am having a similar issue and need help. I have a 2000 Tundra with 120k miles. My rough idle issues happen only when I am
coming to a stop. Right before the truck stops I get some rough vibration that almost feels like the transmission (but I put the
truck in Neutral when coming to a stop and it still happens) and the engine idles rough and sounds like it's about to stall out.
Once stopped...it idles fine. So it only happens right before I come to a stop either in gear or neutral..

Any ideas?????

thanks,
 

·
Super Moderator
2015 Toyota Tundra DC SR5 5.7L
Joined
·
8,562 Posts
I too am having a similar issue and need help. I have a 2000 Tundra with 120k miles. My rough idle issues happen only when I am
coming to a stop. Right before the truck stops I get some rough vibration that almost feels like the transmission (but I put the
truck in Neutral when coming to a stop and it still happens) and the engine idles rough and sounds like it's about to stall out.
Once stopped...it idles fine. So it only happens right before I come to a stop either in gear or neutral..

Any ideas?????

thanks,
Did you do the above recommendations?
 

·
Super Moderator
Joined
·
1,772 Posts
My 05 tundra has 88k miles on it. I have noticed it is starting to idol rough. Any suggestions?
Also, when i first start it up and go to pull out i get a....what feels like a rumble or shake in the rear........only when i first start and pull out.....after that I don't notice it.
No way to fix this. Mine does it too.

I've tried replacing the Iridium spark plugs over 5 times in the last 10,000 miles w/ the TRD supercharger . Denso and NGK spark plugs. No change. Everything is clean and new: New Amsoil nano-fiber Air Filter, New oil , oil filter. Amsoil PI fuel additive for the last 5 fill-ups or more. I've also got Brand new Toyota Catalytic converters now which the previous ones disintegrated and had to be changed around 98,000 miles. Cleaned the Throttle body numerous times recently. Also cleaned the MAF lots of times. New intake gaskets from the supercharger installation...., no vacuum leaks. And new headers with Percy's high Performance aluminum gaskets. And no leaks at the headers either or anywhere downstream of the exhaust. Everything is new, practically everywhere.

And guess what , its still rough. Live with it.
Just like yours.... the Motor and everything is smooth once you're going. My friends' C6 Corvette's idle is waaay rougher. So the Tundra is still better in the idle department :D
 

·
Premium Member
Joined
·
7,925 Posts
Coil Packs?
 

·
Premium Member
Joined
·
2,875 Posts
When the crank shaft position sensor goes out of alignment it can also cause a rough idle.
 

·
Super Moderator
Joined
·
1,772 Posts
Coil Packs?
Ohh... I forgot to mention those on mine ..... I replaced those too. All the Vacuum lines, clamp, ect.

And mine still has a rough idle.

Crank position sensor out of alignment. What a joke. You're kidding right?

I beat the crap out of my truck and my timing belt, and everything inside there was inspected by Toyota mechanics. I was told everything was flawless and looked good. They said it really Didn't even need to be done and they all were surprised at how good everything looked. Being they know how I drive my truck. Offroading, driving in the winter, driving into ponds, deep snow, ect. I had them test the crank position, cam sensor, ect. All within specification.

Do you have a lift at all? I noticed as I cranked down on the the coil lifting the truck on mine that it transfers more vibration of every kind. Especially at idle. Not just driving.

Anyhow good luck skeeterman on finding yer problem you have. Just sharing my personal experiences on my truck but I all I found out replacing everything was I just wasted cash. Because the problem still exists. I guess I could try new coilovers next.
 
1 - 12 of 12 Posts
Top