Toyota Tundra Forums banner

21 - 23 of 23 Posts

·
Registered
Joined
·
2 Posts
I have had a Pioneer Avic D6 in my sequoia for a couple of years. I fought and fought with the installation and got it done ok, but could never bypass the safety features. I finally just accepted that there would be no video. I can live with that. But the thing that just torqued me, is that you can not even type in an address in the nav, or do a regional poi search. When you are moving, it all greys out. So, I have to pull over to type into the nav......If I am going to pull over, I can pull out a freaking map!!! That pissed me off. Besides, the nav is far from accurate. So, after all that time, I am selling the Pioneer. I just installed a Kenwood DNX7140. Holy cow! Super easy installation! Safety bypass is a no-brainer! The nav (which is by garmin) is dead-on. Even the touch screen is much more responsive. Please, take it from my experience. Do NOT get sucked into the lower price of the Pioneer. I fell for it and paid in the long run. It is NOT worth the trouble!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
12 Posts
Thanks a lot for posting this. Wanted to add that the 2001 Sequioa is a YELLOW reverse wire but it is in the same position. I screwed up at first because I went for the BLACK W/ RED on the same plug, which is just a +12V.
 

·
Registered
Joined
·
113 Posts
Thanks a lot for posting this. Wanted to add that the 2001 Sequioa is a YELLOW reverse wire but it is in the same position. I screwed up at first because I went for the BLACK W/ RED on the same plug, which is just a +12V.
When you used the black w/ red wire did the camera work? My camera works but it doesn't switch automatically when you put it in reverse.
 
21 - 23 of 23 Posts
Top