Toyota Tundra Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2004 XLE with a factory nav system. I recently purchased this van and never checked the nav.. what a mistake. I get a message that reads "incorrect program disk. Please insert the proper disk. "

So far this is what I have tried.

Pulled the (2) fuse's
Disconnected battery for several hours
Removed Nav unit from car for several weeks
Pulled Battery for Nav unit circuit board
Tried to upgrade from 3.1 to 5.1

I really would like to get this system working. Any help anybody could offer would be greatly appreciated.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Where are all the experts?

I have waited months and months with no response. I was looking for help and nada.
 

·
Premium Member
Joined
·
2,829 Posts
try sienna forums, they have a lot more info on navigations.
also you have very old system, that is why not that much support is available for it.
 

·
Premium Member
Joined
·
670 Posts
I have a 2004 XLE with a factory nav system. I recently purchased this van and never checked the nav.. what a mistake. I get a message that reads "incorrect program disk. Please insert the proper disk. "

So far this is what I have tried.

Pulled the (2) fuse's
Disconnected battery for several hours
Removed Nav unit from car for several weeks
Pulled Battery for Nav unit circuit board
Tried to upgrade from 3.1 to 5.1

I really would like to get this system working. Any help anybody could offer would be greatly appreciated.
Assuming your NAV came with a NAV DVD disc, did you try to "reload" it by pulling the correct radio/NAV unit fuse? It's important to eject the disc, then turn-off ignition, then pull fuse & leave out for 2 min minimum, reinstall & try to load disc...if it doesn't load, maybe its the wrong disc?

Brad
 
1 - 4 of 4 Posts
Top