Toyota Tundra Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My Tundra has 1400 miles. When I accelerate from a stop it shifts nice, but when I slow to around 5-10 mph and then try to accelerate the transmissions seems to hunt for the correct gear. The engines revs high and then goes into gear. Any advice??
 

·
Registered
Joined
·
1,067 Posts
The transmission on these trucks is very weird and takes some getting used to. Supposedly they "learn" your driving style and adapt to that over time. If you recently changed the way you drive then maybe it's trying to relearn. As long as it doesn't do it every time and you don't feel like your being rearend when you take off or slow down you should be okay.
 

·
Mark it eight, Dude...
Joined
·
4,373 Posts

·
Premium Member
Joined
·
846 Posts
Your transmission computer is still in the learning curve. Be patient it will eventually learn your habits and respond way better.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks for the encouragement. I hope ya'll are correct. I don't quite understand how it learns, but good on it.
 

·
Registered
Joined
·
820 Posts
its normal. my truck has 42k and does this and my wife's 4 runner has 100k and hers does this too.
 

·
Registered
Joined
·
56 Posts
mine did it in the 07 tundra ,lasted about a month or so..... I just traded for a 2010 and am in the middle of it again can't wait for it to stop. or should I say learn...... lol..... but no worries it will smooth out for ya.
 
1 - 8 of 8 Posts
Top