Toyota Tundra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Several electrical functions have stopped working on my 2001 Tundra: Power door locks, power windows after ignition shut-off, lights on after ignition shut-off, cargo light, maybe more. I have visually checked all the fuses, and they appear to be good.

A few years ago, my ignition switch was replaced, but not completely reconnected - the truck does not sense when the key is in the ignition but turned off.

Any ideas where to look for the problems?

Thanks.
 

·
Registered
Joined
·
756 Posts
did this all happen at once? I'd start with trying to find what they all have in common. the obvious is the ignition, but I'm not sure how that would effect windows and locks. Possable relay under the hood that they all run to? I know it isn't much but you have a strange one there. Check the trucks ground?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The ignition sensor problem is about 4 years old. The only problem with that is that I can now lock my keys inside the truck if I leave them in the ignition. I haven't but I've come close. It seems pretty obvious that they forgot to reconnect a wire when the installed the new ignition.

The other four or more problems happened all at once, most likely. I didn't notice them at once - first the door locks, then the others over about a week. Under normal operation, the windows and cargo light are both on timers. The cargo light, windows, and headlights are all affected by the door opening. Interestingly, the light around the ignition still works, even though it's on a timer and triggered the door opening.

I'd love to get my hands on a wiring diagram and try to see how this is all linked up. Any thoughts?
 

·
Registered
Joined
·
756 Posts
there was a technical section to the site before, you had to pay a membership fee and you could see the scamatics and what not. There are members who are Toyota Techs but the quickest way would be maybe a library for a Chiliton's manual or just buy one from an auto parts store. seems to all come back to the ignition not seeing the key. Any chance of speaking to whoever did the original work? They might be able to tell you more about the circuit. If it all happened at once I would think a relay or that ignition. Good luck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I could talk to the original guy, but I don't think I trust his work. There are other issues besides the ignition switch.

I'm thinking it's not related to the key sensor, since everything else worked for about 4 years. And the windows would operate for something like 45 seconds after shutting off the engine, with or without the key in the ignition, as long as neither door was opened. (Why? I don't know, but this is proper operation according to the manual.) Now they don't work whether or not the key is in the ignition. Also, the power locks worked just fine, and now they never work.

I'm thinking a connection has opened somewhere... any idea where to look?
 
1 - 8 of 8 Posts
Top