Toyota Tundra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My Tundra smells like something is getting hot from underthe hood. The temperature gauge isreading normal (just below horizontal) and there is no check engine light. This issue has been going on for about 2-3months now. The truck threw a code /check engine light a couple of weeks ago. O2 sensor #2 Bank 2 malfunction and Bank #1 running lean. I replaced the O2 sensor and since then therehas been no codes or pending codes. Therehas not been any noticeable performance change of the truck. Normal maintenance has been preformed on thetruck since brand new. So I am lost asto what my is causing the smell and minor lose of gpm. Any comments and or suggestions would begreat.
2005 Tundra SR5 Double Cab V8 4.7 with 173kmiles.
 

·
Registered
Joined
·
9 Posts
I too have a similar smell. I changed the radiator out when i did my timing belt and water pump at about 5,000 ago. Smell started after the repairs were made. 2005 DC SR5 4x2 194,000.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
5 Speed -- I will look at the radiator this evening, however the truck shows no sign of any leaks or lose of fluids.

nieto7782 -- I to had my timing belt with water pump replaced about 8k miles ago (back in May 2014). The coolant was flushed and replaced at the same time. I thought after that work maybe I had a hose againist something getting hot. I have not been able to find anything yet. The smell is always noticable when I first get out of my truck and dissipates after 5 or 10 minutes.
 
1 - 5 of 5 Posts
Top