Toyota Tundra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
I have a 2006 Tundra Limited 4WD Double Cab, and am starting to experience what I think is the infamous squealing sound discussed on other postings to this forum. Mine is not a "chirp chirp chirp" but sounds more like a constant squealing sound. It happens intermittently, but when it does happen, the sound is pretty constant, if that makes any sense.

I searched through this forum, as I remembered that TSB EG026-06 was written for this. But in examining this TSB, my truck's VIN was well outside the point at which the change was made on the production line. This makes sense, since my Tundra was made in Mid-December 2006, probably among the last Tundras made for that model year.

Has anyone experienced this problem for which TSB EG026-06 was not applicable? I know many tried implementing this TSB and it didn't fix the problem - I am not referring to those - I am wondering if the problem has a different cause since the TSB doesn't apply to my vehicle...Comments? Although my vehicle is outside the basic warranty (I have about 63,000 miles) I do have a platinum agreement extended warranty. I'm just wondering the best way to approach the problem with my dealer so I can hopefully get it fixed right the first time.
 

·
Premium Member
Joined
·
116 Posts
I have had this problem with both my Tundra's. I installed the Gatorback belt and have not had the problem since. Cheap and easy fix. I would not be covered by your Platinum warranty but still worth the $40 or so and no more noise.
 

·
Registered
Joined
·
8 Posts
I have a 2006 Tundra Limited 4WD Double Cab, and am starting to experience what I think is the infamous squealing sound discussed on other postings to this forum. Mine is not a "chirp chirp chirp" but sounds more like a constant squealing sound. It happens intermittently, but when it does happen, the sound is pretty constant, if that makes any sense.

I searched through this forum, as I remembered that TSB EG026-06 was written for this. But in examining this TSB, my truck's VIN was well outside the point at which the change was made on the production line. This makes sense, since my Tundra was made in Mid-December 2006, probably among the last Tundras made for that model year.

Has anyone experienced this problem for which TSB EG026-06 was not applicable? I know many tried implementing this TSB and it didn't fix the problem - I am not referring to those - I am wondering if the problem has a different cause since the TSB doesn't apply to my vehicle...Comments? Although my vehicle is outside the basic warranty (I have about 63,000 miles) I do have a platinum agreement extended warranty. I'm just wondering the best way to approach the problem with my dealer so I can hopefully get it fixed right the first time.
I have the same issue. I can't help you, but what is TSB EG026-06? If you find a resolution I'd love to know too. I notice that I get the sound when it's wet and/or cold. I live in New England and winter and wet days is when it's noticeable.
 

·
Registered
Joined
·
1 Posts
2006 Tundra Doula Cab Limited DVD/Navigation (Massachusetts)

I have had the "Belt Squeal" going on 4 years. I had been told, the pulleys, belt tensioner assembly, and belt have all been replaced. Actually, I have the repair orders claiming the work was done. Well, they did attempt to do some work on the prob. On one occasion, after being in the shop for 3 days, I brought it home and it leaked out all the antifreeze overnight. My radiator was punctured multiple times by the dealership. I only had 3,600 mi on it at the time.

It was serviced on 5 different occasions with 3 different dealers when under warranty. This started at 3,000mi and I now have 46,000mi. It's constant when raining or humid and seemed better in the cold/dry weather. Toyota gave up on me and I gave up on them. I'm looking to trade-in to the dealer I purchased from- they shouldn't have a problem with the truck, they have given it a clean bill of health twice. PLEASE!!

I also have a repair order stating the "GatorBack" belt was installed. Any ideas??
 

·
Premium Member
Joined
·
5,061 Posts
I also have a repair order stating the "GatorBack" belt was installed. Any ideas??
Pop the hood and check that belt to ensure it says goodyear on it. If it doesn't, your dealer didn't bother making a parts run for the belt, but pulled a toyota belt off their shelf instead.
 
1 - 6 of 6 Posts
Top