Toyota Tundra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
hello, new member here, i have been lurking for a few weeks and finally got a tundra 10 days ago( i love it).i have read the post on oil leaks and piston slap and dash rattle.i have none so far at 550 miles. i'm listing my circumstances and wondering can these problems be traced to one plant or climate zone. i do not wish to start "my truck is better than yours", but am interested.conditions: mine had 6mi on it off the truck{pre ordered}, not much below 40 degrees since i've had it and garage kept,built in indiana, dc 4x4 ltd , easy driver(i don't think it's been above 2300rpm yet).
 

·
Registered
Joined
·
848 Posts
i had the oil leak .. it was a simple fix of the o-ring on the dipstick tube .. not a design error but a instalation error ... the guy that originally installed it just forced it in and cut the 0-ring .. easy fix and only cost toyota 26 bucks including labor but then the guy forgot to put the oil cap back on and caused a major mess in my engine bay :td:
 

·
Registered
Joined
·
161 Posts
Discussion Starter #3
so was it one guy piching the o-rings?
 

·
Registered
Joined
·
161 Posts
Discussion Starter #5
it would be worth knowing if one guy was pinching the o-rings at just one plant ....maybe the dash rattle can be narrowed to one plant?
 

·
Registered
Joined
·
621 Posts
I have a 4.7L Indiana built truck. Everything seems fine so far. I just drove it over to our airplane and back. I got to do two favorite things. Fly the airplane and drive the truck.
 
1 - 6 of 6 Posts
Top