Toyota Tundra Forums banner

1 - 20 of 86 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Replaced wheels and tires Saturday and still no light. Glad the system works so well. Don't know how I am going to live without big brother telling me my tires are going flat. At least I didn't waste the time to switch the junk to my new wheels.


Say I'm going 70mph, my tire blows out, I crash, Can I sue Toyota since my dash doesn't say I have a flat. Hmm. They might want to check on this. Especially if it happened while my throttle was stuck. Lol
 

·
Registered
Joined
·
7,461 Posts
it'll come on. mine did it after about 4 days.....its old news by the way. the system detects low presure signals much faster than it setting codes for not reading the sensors at all...
 

·
Registered
Joined
·
148 Posts
Discussion Starter #3
I wondered. My last tundra took over a month to come on. My Tacoma came on instantly as soon as I pulled out of garage.
 

·
Premium Member
Joined
·
5,461 Posts
Yup! If you read the thread that's floating around about a recall the NHTSA spec says that TPMS has 20 minutes to respond to low pressure.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #5
Been off site a couple years. Had a company truck. Now a new tundra and haven't searched for everything yet. I know I'm acting like a noob to some but oh well. Just thought it is funny it is supposed to tell us we have a flat and doesn't even know it is gone.
 

·
Registered
Joined
·
2,792 Posts
Don't give them any ideas. Before you know it they will program the ECU to go into Limp mode when the TPMS triggers the light.
Honestly, I can't believe they don't already do that. I suppose a collision from the rear every time someone runs over a nail while doing 75mph down the freeway isn't worth the lawsuits involved in making that a reality.

...or something like that...I'm tired. :sleep:
 

·
Registered
Joined
·
7,461 Posts
the one that gets me is teh onstar one. i got an email the other day in teh yukon that our tires were low....got the email on my phone. so...here i am driving, the truck didnt set a low tire warning but i have to read a tiny email on a tiny phone screen hahaha. now thats retarded. sure enough i check the display (cause GM actually tells u the PSI in each tire on the display) and they had dropped from 36 to 32 (cool weather) but not low enough to trigger the idiot lights...
 

·
Registered
Joined
·
18 Posts
I have an '07 Tundra, and I know there are a lot of solutions out there to disable the TPMS light, but I think that I have found a way to trick the computer into believing that everything is working correctly without removing the dash or having to store those stupid sensors in pressurized container in the truck. I bought $5 worth of stuff at Radio Shack and it took me about 30 minutes.

I soldered a 12 volt Zener diode, a 1/4 watt 2.2k ohm resister and a 1/4 watt 1k ohm resister together to look like this. Be careful with the diode to ensure that it is facing the correct way because it only lets the voltage flow one direction.

Behind the glove box is a small grey box with a 12 pin connector to it. You can do this mod without removing the glove box if you don't mind spending some time on your back in the floorboard.

Remove that connector and then on the left side of the connector (the side with the clip) remove the light blue wire (5th one from the top). There is a compression fitting on the side of the connector that you will have to pop out approximately 1mm and then you can use a pin to remove that metal connector out of the plastic harness from the connection side. This is fairly simple to accomplish (hard to explain) but only necessary if you think that you may want to return it to factory operation at some time, otherwise you can clip the light blue wire.

Next step is to connect the resistor end of the series that you soldered together to the light blue wire. Then reconnect the plastic connector to the computer and stick the diode end into the back of the plastic connector so it makes contact with the yellow wire in the top right position.

This sends approximately 4.4 volts from the computer thru the light blue wire to the combination meter to tell the system that there is no fault.

I have had this system on my truck now for about a month and have never seen that stupid light (it doesn't even show up on start-up since it always thinks everything is working perfect). And just to check this theory I swapped it back to factory spec today and the light came right back on...put it back the way I had it and the light went right back out. If anyone needs more pictures or additional info I would be happy to provide it. This fix saved me over $600 for 4 new sensors and the reprograming fee. Hopefully it will help someone else too.
 

Attachments

·
Registered
Joined
·
1,524 Posts
Outstanding work. I will save this to us when the batteries in my sensors go dead. :ts:

Now go to work on a Mod for the AIP system!

You could keep these mods secret and sell the info to members....might be able to quit your day job! :becky:
 

·
Registered
Joined
·
1,659 Posts
I am subscribing to this one, rep points to you when your post count goes up and I am out of jail
 

·
Registered
Joined
·
18 Posts
This mod has been on my truck for a little over a month now and it has worked just fine. I put the system back to factory spec yesterday and the light came right back on since the sensors are removed, then added my mod back and the light went back out. This tells me that the system is working, I just tricked it into believing that the sensors are working correctly
 

·
Registered
Joined
·
18 Posts
Outstanding work. I will save this to us when the batteries in my sensors go dead. :ts:

Now go to work on a Mod for the AIP system!

You could keep these mods secret and sell the info to members....might be able to quit your day job! :becky:
Thanks, but I like my day job and wouldn't feel right charging for something that is so easy to do.
 

·
Registered
Joined
·
41 Posts
This worked like a charm! Saved me $220, what the dealer wants to replace one sensor (parts and labor). I just wanted the stupid light to go out. Awesome!
 
1 - 20 of 86 Posts
Top