Toyota Tundra Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an 05 Sequoia Limited. I start the engine, the outside air temperature isn't reading, the doors won't lock when placed in gear, the engine coolant temperature gauge isn't reading, and the dash illumination comes on after truck is started (headlights are off). All of these things work when the key is turned to run with the engine off. Also the tilt button doesn't work which may or may not have been that way before. I don't open the sunroof much. I'm lost, I don't even know where to begin. Any ideas? Thanks
 

·
Registered
Joined
·
231 Posts
Despite the description of the issues, you are not telling us anything about the truck. How old is the battery? I'd start there. A low battery can wreck havoc on your systems.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yeah, it's not the battery, I tested it recently it had 900 CCA. I drive this truck everyday. I don't really have anymore info about the truck.
 

·
Registered
Joined
·
231 Posts
If the battery tested good... and you can verify that the cables running from the battery are not corroded out (common issue), then I would try this. Unhook the negative battery terminal overnight. In the AM, reconnect the battery and start the truck. Let it run for about 5 minutes. This resets the computer which potentially could be giving you these issues. If that does not work, I'd plug it in and figure out which codes are showing up. Good luck. Hope you don't have a salvaged flood car on your hands.
 
1 - 4 of 4 Posts
Top