Toyota Tundra Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Just last week picked up a new-to-me 06 Tundra with 75k on the odo. This week, both power windows are kaput. Nothing at all from driver or passenger side controls. Of course checked 30 amp fuse and is fine. Power door locks and mirror still okay. Checked for loose wiring and pulled off the door panel, but no luck. They started working again for about a minute yesterday while i was fiddling around and then quit again.

Are there any known problems or quick fixes anyone is aware of. Should I check somewhere else..does it sound like a relay somewhere? Any thoughts or help is most appreciated!
 

·
Registered
Joined
·
6,779 Posts
Mine did that from time to time, last time it happened, I popped out the control panel on the driver side (carefully), and the stupid plug was barely hanging on. If it isn't that, and the relay's and fuses are good, there must be a bad connection or wire somewhere. It a possibility since both switches are not functional. I don't think anything else could be the culprit. When mine did it, it was the windows and door locks.
Good luck.
 

·
Registered
Joined
·
300 Posts
You should change the fuse anyway and see if that does it. I have seen plenty of fuses that looked fine, but were actually blown.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I would say yes to replacing the fuse anyway, except that the 30 amp "power" fuse is also for the door locks and power mirrors which both work fine. When I pull the fuse, those go out as well so fuse is fine.

Thanks for responses. Guess i'll be making an appointment with the service department soon....
 
1 - 5 of 5 Posts
Top