Toyota Tundra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 tundra with the trailer package. According to the Tundra diagram on this site, I have a RV1 type plug. I am measuring the current off the Tundra supplied harness before connecting it to my Tekonsha. I get a good 13.97 volt current on the primary leads and a good 12.5 volt current on the green lead for the turn signal and brake lights; however, I get nothing on the red lead for the brakes. 0.00 Volts idle and 0.00 volts with the brake depressed. The harness continuity checks out, so where is the signal being lost. I expected to see current on the brake lead when depressed in order to activate the Teknonsha brake controller for my boat trailer????
 

·
Registered
Joined
·
3,058 Posts
I thought the brake controller was activated by the brake switch and the brake controller sent power to the trailer plug.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The sequence is Brake Pedal Activates, Harness sends signal to Brake controller, Brake Controller sends signal to trailer, Trailer brake engages based on signal from the Tekonsha brake controller. Problem here is that the Tundra brake is not sending a signal to the Tekonsha brake controller. Therefore, no brakes on the trailer and one heck of an exciting ride in traffic.
 

·
Registered
Joined
·
3,058 Posts
Yeah, that's what I said. Are you sure there isn't another relay that needs to be added to make it work? Like the brake switch signals a relay that powers the brake controller?
 
1 - 4 of 4 Posts
Top